Hex keeps flipping over on its back when taking off (RESOLVED)

Hello ArduPilot fans. I need your help.

I changed my DJI F550 hex from PX4 to ArduPilot 4.0. It had many flights with PX4 but we’re changing over to Ardupilot and converting all our drones. After initial firmware load and calibration I attempted to fly it. Flipped over as it was taking off. So I checked the motor sequencing on the Ardupilot quick start and sure enough, it was different from PX4. So I made the changes and the same thing happened. Thinking maybe I made a mistake, I redid the motor connections, this time labeling the servo plugs with the proper controller channel to avoid mistakes. Re-calibrated again. Checked the stick movements on the ground to see if the motors were making the frame move in the right directions, and everything was OK. Tried to takeoff and it immediately flipped on its back.

Now I’m completely puzzled. It’s behaving like a quad with the props in the wrong places. Yet the props can only be put on the motors one way because they have right and left hand threads. Has there been a change in motor sequence from earlier versions of the firmware? I’m at a loss as to how to fix this. Has anyone else seen this behavior? I could use some expert help.


Post bin file please.

Motor directions and positions are the same for PX4 and Arducopter, so maybe frame type is set wrong.

If it is flipping in ROLL, go into the radio and reverse the Aileron channel.

If it is flipping in pitch, reverse the Elevator channel.

If it does it on its own, reversing channels won’t fix it. Need a bin file to check what is going on.
A quad with reversed roll and pitch on tx will go the wrong way when giving input but it is still perfectly able to fly.

Check the FRAME_CLASS and FRAME_TYPE for a Hex. Look at the Servo out assignments. SERVO1_FUNCTION thru SERVO6_FUNCTION (33-38). Or SERVO9-14 if using the AUX outputs. If the later BRD_PWM_COUNT to 6.

Then run Motor Test in Mission Planner to check for proper connection order and direction.

Need some direction. I have the file in a directory, but how do I post it here?


If it’s just the parameter file attache it directly with the Upload icon. If it’s a .bin log file attache a link to it after putting it in a cloud storage site (Dropbox, etc)

When I try to upload the file I get this error message:

Sorry, that file is too big (maximum size is 4500kb). Why not upload your large file to a cloud sharing service, then paste the link?

The size of the bin file is 1396 KB so this is a surprising response.


Then either do that or attache the parameter file.

What was the result of the Motor Test?

Here is the param file, but I was asked for the bin file.

2020-05-26 16-38-46.log.param (17.8 KB)


The motor test was perfect. In Ardupilot each motor was started individually, and then in sequence and it all went well. I even tested each motor/ESC separately with a servo tester, and everything was OK.

In this order when the A-F buttons are pressed? Sorry to belabor the point but this is almost always the problem. Nothing obvious I see in the parameter file so posting a link to the .bin file from the last flight attempt could be useful.

Hexa Motor Test

Yes. That is the sequence I observed.

I downloaded Dropbox and am working thru the process to grant access as a shared file.

Here’s the bin file.


Is the Flight Controllers orientation typical? Is the horizon centered in the Mission planners HUD with the craft level? You can clearly see it’s commanding the front motors high, rear motors low with no elevator input jiving with what you are stating.

To me looks like correction is reversed, as soon as the hexa pitches the board reacts increasing some motors and decrrasing others to counteract but it makes it worse and worse until flip. In my opinion board has not set correct direction or motors are not plugged correctly. If you already checked motors than check board orientation.

This Pixhawk is installed in default position, horizontal and pointing straight ahead. HUD is normal for horizon. This drone has flown before with PX4 so I know its set up right. But it doesn’t like Ardupilot for some reason. As for the motors, I have plugged them in three times using the Ardupilot quick start tutorial and the motor rotations are as shown in the diagram posted above. It always behaves the same. I’m thinking there must be a parameter someplace that is affecting this.


On the Mission Plannerr Radio calibration screen does the green Pitch bar move down when the Transmitter stick is pushed up? Reaching now because on the attempt I graphed above there was no pitch input. But not sure what else to suggest assuming all other options have been covered.