Here V2+ compass not detected by Pixhawk1

I recently got a RTK Here V2+ module. Long story short, the RTK feature works but the magnetometer is not detected. Until I replaced APM GPS with RTK I had two compasses working (internal and external). Now only internal is detected. I need the external compass to work, in my TradHeli Pixhawk is in a very noisy location.

I saw the thread at However it looks like the problem with Pixhawk1 was never solved. Magnetometer IC in my unit is the ICM20948. Is there any solution for my problem? Would switching Here V2 module from I2C to CAN help?

Magnetometer in the Here V2 will show as the AK09916/7 this is supported in PH1.

Well, it doesn’t show in HW ID page. I confirmed that moving Here V2 unit doesn’t change the magnetometer readings. The detected one is the internal Pixhawk magnetometer. Shouldn’t there be more detected devices apart from the compass?

Check your compass mask

@proficnc I tried masking out everything but ICM20948 or AK09916 and it still doesn’t detect it.

Can you show me how you have plugged it in?

Here V2 is connected to GPS, I2C and Switch port. I2C communication should be working, because Here status LEDs are flashing the same way as Pixhawk.

The LEDs are working?
At this point, I would suggest RMA’ing the unit, assume it’s faulty and try another