Here GPS without RTK on Mission Planner?


I purchased the Here GNSS GPS without the Base Station/RTK (the predecessor to Here+, which has been discontinued). I have searched all over the internet for resources on how to upload firmware, connect to the pixhawk 2.1, or generally how to do anything with this GPS with no luck.

Is anyone on here using this version of Here? I have a quad using pixhawk 2.1 on mission planner and am stuck on flashing blue LEDs indicating the GPS has no fix, and there is no USB on this version of Here so I am unsure how to get the firmware onto the GPS. Am I going to have to upgrade to the Here+? Any help is appreciated!

I believe you have to open the plastic puck, and use the included USB cable to update the firmware. I’ve done this to multiple Here+.

I’m no pro or dev but went through the same problem to and I dont wanted to do any hardware chnages to my modul. Went lucky with this option…please refer to the link that follows Just follow the instructions given in the firtst part of the wiki article if you expire any connection (pass through) problems it could be related to a wrong baudrate in the connection settings but in my case everything went well without any problems and you can acces everything through the Ublox U-center app on your pc by passing the usb connection through MP. I think if you dont need centimeter-level accuracy there no reason to upgrade to here+ but there is a new version of the “Here”-GPS available soon the promises sound good but i personaly have no experience with the new version but Im thinking of giving it a try! Link to the specs: Hope this helped you a bit!

Some additional notes: I think for the “hard”-solution you need at least an ftdi-cable to connect your Here GNSS directly to an usb port of your pc and in my case (I assume mine is the same as yours) it was the easiest way with the passthrough solution.
There should be no problem because the Here uses an Ublox (M8N) chip wich is accesable through the Ublox u center app ( you simply passthrough the ublox (Here GNSS) signal over the usb port of your Pixhawk.
Connect your gps to the gps1 port of your pixhawk.
I think its best to download, update, and use the latest Beta-Version of Missionplanner. In my case this solved several issues including available preferences not available in the stable version (Im using arducopter 3.6.0rc7)
Have you tested your gps indoors or outdoors with clear sky view for the gps. If the number of stattelites recognized by the gps is to low or the hdop is to high you simply wont get a fix and the pixhawk indicates by the blue light that your only ready to takeoff within non-gps modes as stabilze (standard arming flightmode) or alt-hold.
Is the compass of the GPS recognized by the pixhawk?
You can verify if the Here is recognized correct by having a look on the “Messages”-section of missionplanners quicktab panel.
(Open Missionplanner, select the messages tab, connect the pixhawk with connected gps to your pc, as soon as you hear the connection tone click the connect button and if the gps is correctly recognized something like "GPS detected as Ublox M8N followed by several number and the baudrate the gps is working at.)

Just leave the gps be… The Pixhawk is by default programmed to force the gps to send the right messages… It is called autoconfig. You can try and mess around with the settings in ucenter but as soon as you connect the gps to the pixhawk it will force the module to get the right messages out.

And just to clarify: The Here is not really comparable with the Here+ as if they have totally different GPS chips… The Here uses the M8N by ublox and the Here+ the M8P which has RTK capabilitys…

1 Like

Solved: I initially thought it was an issue with the building I was in not having strong sat signals get through, but going outside did not help this. Turns out I had to cycle power to the drone with my Lipo with no USB while outside with a clear skyview and this did the trick. I really appreciate all of the quick responses from everybody though! Your help is really, REALLY appreciated from noobies like me.

Dont mess up a running machine is the best choice or things could be worse than before but in the last month I personaly had corrupted paramaters. Perhaps due to rapid changes in the beta firmwares so missionplanner sometimes lags behind (Name changes of parameters etc). My thought was the autoconfig parameter @Niels mentioned in his post in my case it was set to 0 so autoconfig was disabled! The feeling as the sweat on my face, caused by thought of an hardware fault was unbelievable when i recognized the corrupted parameter.
And yes they are really not comparable…espacilly when it comes to costs:grinning:
@KS33 Don’t worry I’m a noobie too but somehow we all sit in the same boat and the kowledge in this forum is fantastics and saved my ass so many times i can’t even count it. Have a nice airtime @Niels @KS33