Here GNSS GPS not detected by Pixhawk 2


I have the HERE GNSS GPS module connected to Pixhawk 2 and the GPS is not present in the Mission Planner.
The compass works fine and the arming button. The side led’s also do not work.
I flashed with APM:Copter 3.5.5 Quad
I cannot connect GPS module to PC because it has no usb connection.
All the stuff is brand new pirchased here:
Does anyone know what might be wrong? Could it be a hardware issue?


I just found out it works as GPS2 (SERIAL4) though the side LEDs still dont work. Anyone knows how these leds work? (thrugh serial or I2C?).

I also noticed in the mission planner that SR3_ADSB and all the other SR3_ parameters are set to stream at 5, 2 Hz. Is that ok?

1 Like

Im having exactly the same problem, haven’t tried on serial 4 so havent had any connection at all. But have tried a tersus receiver i have which worked straight away.


I have sent the Pixhawk back to 3DXR store and am waiting to receive a new one.

I received the new Pixhawk and now the GPS works. Case closed.

Can I bump this thread? I’m in a rush to get my pixhawk build done. It seems I have the same problem as OP. Has anyone found a solution to this beside a return? I don’t think the Pixhawk 2.1 comes with the cables to connect the Here GNSS to the GPS 2 port easily

Hi all, I do have the same problem actually. @AndrejSl how did you connect the Here GPS to SERIAL4? Can you share it please?

I’m having the same issue as the original poster. I work in a lab where we have numerous Pixhawk 2’s around and this appears to be a hardware problem. After several hours of switching components and trying to debug, the only work around I can find is to send the pixhawk back to where you bought it from. For me, it appears to just be a Pixhawk 2 IO board problem. The cube and the GPS both seem to work just fine.

Well i basically took apart the GPS module and soldered the cables to pins. Keep in mind though that the status LEDs on the GPS module will not work.

Had a very similar problem (GPS working poorly and recognized as a nmea 9600 instead of ublox at 115k), sent the Pixhawk 2.1 back and the replacment worked straight away with no issues. So i guess mine is an hardware prob on the carrier board.