Here 3 Can protocol

Hello
I am running into some problems using the here 3 gps.

Ive followed the manual on the cubepilot website to configure the here3 and see which parameters i needed to change.

But after i change all the parameters the gps didn’t show up in the uavcan setup page. After a few reboots en switching the can cable from can 1 to can 2 and back a couple times it shows up. But if i reboot the pixhawk the gps doesn’t show up only after if reboot it a couple times.

And if i try to calibrate it it doesn’t work everytime. If i get a good calibration i stil get a warning bad compass health.

Iam running the ardupilot 4.03 on a cube orange.
Ive tried this with multiple cubes, cables and here3’s and i can’t get it to work properly

Does anyone who has the here 3 working some tips or things to try to get the here 3 working?

It should just work tbh, have you tried the daily build to see if its any more stable but I have tried the Here3 on both Black and Orange with out issue,

Have you changed your brd_boot_delay setting? I was never able to get mine to come up with a delay of 0. If you change it to 5000 or 6000 you should not have any further issues

If using cube orange, connect the here3 in CAN 1 select com port xx SLCAN and appropriate baud rate, don’t hit connect, goto UAV/CAN from additional hardware and hit CAN1 scan from option. This worked for me.

I am using dual here3 setup. I have successfully setup tow different node values.