Help with PPM Configuration on RFD900x 2.0 and TXMOD 2.2

Hi everyone,

I’m trying to configure the PPM output of the RFD900x 2.0 with TXMOD 2.2 to eliminate the need for a separate RX. I’ve completed the basic setup using the wizard, but I’m stuck on how to properly configure PPM.

My Goal:

  • Utilize only the RFD900x for both tlm and PPM output.
  • Control a plane using the RFD900x’s PPM output.

What I’ve Done:

  • Completed the basic RFD900x configuration through the wizard.
  • Enabled PPM output in the RFD900x settings.

What I Need:

  • Detailed instructions on configuring PPM on the RFD900x and TXMOD 2.2.
  • Information on which parameters to configure in TXMOD for proper operation with the RFD900x’s PPM output.
  • Troubleshooting tips in case the PPM output isn’t functioning as expected.

Any assistance you can provide would be greatly appreciated.

Thank you in advance for your help.

Best regards

Use this guide

and use SBUS if possible, but you can substitute PPM if you really need to.
SBUS has the advantage of signalling a failsafe in the serial data instead of relying (only) on throttle below failsafe (and channels going to values set when the “PPM failsafe” button was clicked)
SBUS is a serial protocol with RSSI info and other things contained within, where PPM is more like old fashioned PWM.

2 Likes

Hi, thanks for the tutorial, I followed it and it does not work, I am measuring the signal with my toolkitrc charger that has sbus measurement function. the only thing that I think may be wrong is the refresh rate that as seen in the picture I can not go higher, as you indicate in the tutorial, what can I do? I have a TX16S with edgetx.

Maybe show some screenshots of your TXMOD and RFD900X settings
and your wiring.

On my TX16S/EdgeTX the refresh rate is 7.0ms (normal)

This is how I have my setup, and the wiring I am using for testing is 2 and 4 for power and 15 for signal output.

image

The only real difference I can see between mine and yours is S26:AIR_FRAMELEN 4000 should be 120
Mine is at default and I’ve never changed it.

I’ve also set S13:RTSCTS 0 since the screenshots were taken for that little tutorial, which is how your is now too.