Help! When arming and throttle, vehicle turns over backwards

I’m trying to built a tiny ArduCopter with a Flywoo F745 AIO board on a 2" Whoop frame. But when arming and throttle, it turns over backwards.
Please advise where to check in such cases.

video:

log and parameters:
https://drive.google.com/drive/folders/1hnqiYzn9z-ZEg_Xa567mccjeECmx7A5J

I followed these steps to complete the initial tuning. I used 5" values because 2" ones are not listed.
https://ardupilot.org/copter/docs/setting-up-for-tuning.html
I used BLHeli32Suite to match the direction of rotation of the motor by the following procedure.
https://ardupilot.org/copter/docs/common-blheli32-passthru.html
I followed these steps to complete the ESC calibration
https://ardupilot.org/copter/docs/esc-calibration.html

Configuration

  • Firmware :ArduCopter V4.3.0-dev
  • FC Board :FlyWoo F745 AIO BL_32
  • FlyWoo F745 AIO BL_32 — Copter documentation
  • Telemetry radio :ESP-WROOM-02
  • Motor :URUAV 1102 10000KV
  • Propeller :Emax AVAN Micro 2inch 2035 4 blade propeller
  • RC Reciever/Transmitter :AC200/Futaba 10J
  • GCS :QGroundControl iOS

Thanks.

Use Mission Planners Motor Test function to check order and direction. Read the note and click the link to be sure you understand what order the test is run in when you select the A-D buttons.
Use Mission Planners Initial Parameter Setup, under Mandatory Hardware, to set the initial parameters.

1 Like

Thank you for your comment.
I have confirmed the motor and propeller order and direction. I don’t think there is any problem.

By the way, take a look at this video.

Normally in stabilize mode, when the vehicle is tilted, I think the motor rotates to bring it back to horizontal.
But my ArduPilot vehicle is unresponsive when I tilt it.
This looks like the attitude control is not enabled.
Is there a point to check?

Thanks.

I’m sorry to continue posting.
Looking at the state of the aircraft with QGC, X/Y position control is disabled. I suspect this is the cause. Is there a way to change this?

Thanks.

I don’t know what those characters are next to x/y position control but you have no GPS sats so perhaps it’s no surprise.

The quad shows that it’s pitching nose up (positive angle of pitch in the log, and the artificial horizon in the video), however the rear motors (2&4) are increasing in RPM. So either, as @dkemxr said, you need to verify the motor positions, or there is something wrong with the board orientation/calibration. When you move the quad, does the artificial horizon move correctly? I can’t tell from the video what the front of the quad is so I can’t say what’s right.


Thank you for your comments and kindness.

@dkemxr
Sorry for using Japanese. “無効” in Japanese means disable.
When I checked it in a GPS available environment, “X/Y Position Control” was also disable.

@Allister
The part without GPS is the nose.
image

Also, the artificial horizon is working normally. Please see this video.

Then the motors are not correct. The FC sent the signal to what are identified as the rear motors (2&4) to increase in an attempt to stop the nose up attitude, but it appears that thrust happened in the front.

I got it. How can I change the motor number recognized by FC?

Change SERVOX_FUNCTION to the correct motor outputs. Then check in motor test to make sure they are in the right position.


Use this layout guide to check
image
A1
B4
C2
D3

1 Like

I changed the assignment of SERVOX_FUNCTION and it flew. Thanks to you. thank you very much.

3 Likes