Servers by jDrones

Help Setting Up Traditional Helicopter

In order to troubleshoot your issues I would like to see the latest param file on your controller. So I would like you to download the latest copy of params from it. Use mission planner to connect to your controller and save them to a file. thanks.

I’d like to point out that nobody else’s param file is going to work. There is a param file in the frame params in Mission Planner you can load to tune it for Copter 3.6. But you still have to set all the servo limits and pitch ranges, do all the calibrations, etc. as outlined in the heli setup documentation. There is no shortcut to getting the machine to fly successfully. Helicopters are very unforgiving of improper setup.

Got it thanks . . . going up the steep learning curve inch by inch . . . here is where I am now.
Using the Standard Params tool in Mission Planner, I was able to use the process of elimination to narrow down my failure to pre-arm properly. Accelerometer Calibration (which came back successful, btw) and the RC. Any one or both of these prevent the Arming to proceed.

Bill . . . I’m unable to locate an area in Mission Planner where I can connect to the Transmitter. Maybe I’m looking at it and just don’t see it.
I am feeling better, with all the coaching and suggestions, I did get it to spool up with throttle control, but only after disabling all Arming checks. Now I need to get it to Arm cleanly.
Here are the latest params . . .

STEVE_plus_DEFAULT_plus_ACCcalibrate.param (14.2 KB)

Sorry i wasn’t clear. I meant connect to your mini pixhawk controller. I think what you posted was what I was looking for.

Question withdrawn
20 characters

Help me! , Hirobo Embra 450e is setting Pixfalcon (compatible with Pixhawk mini) Premature Motor Interlock How to turn off Enable is not understood I spend more than 2 months What is the problem?

180709.pdf (47.2 KB)

I’m no expert by any means, but I had to Disable Arming Checks . . . set to 0 . . . to even get my heli to Arm.
Might not be a bad place to start and troubleshoot from there?

Thank you but you can not identify the fault even if you uncheck Arming Can not understand why you can not Arm

Pre Arm Motor Interlock Enable ???

Sorry, I have same problem so Arming Check=0 was only way I could fly today.
Have not figured out problem yet.

Thank you very much. The first helicopter was able to fly This was the same problem with firmware version 3.60 rc, but suddenly Aming was able to fly out now
The same problem has occurred in 2nd Heli Version 3.56 rc is displayed in strange thing Installed this Version 3.55 was installed but there is the same problem QGroundControl often has few parameters displayed This is also unintelligible Is the difference between Version 3.60 rc and Version 3.56 rc? Do you know where Version 3.60 rc is in? Sorry Please help me Do not understand

Sorry, I only use Mission Planner.
Hope someone else can help.

I will try mission planner tonight

Thankyou

Please use the latest daily build of QGC from here https://docs.qgroundcontrol.com/en/releases/daily_builds.html

It is the safest option at the moment

QGroundControl New Version Install now

Thankyou

You will find a new heli setup page for helicopters in the daily build of QGC. For Copter 3.6 there is also a new parameter file you can load that will set the basic tuning defaults for most heli’s that you can download here for QGroundControl.

The tail servo settings may be a bit “hot” in that param file, depending on your tail servo and how much headspeed you are running. If it seems to be a bit too quick on the tail you can reduce the ATC_RAT_YAW P and D gain a bit, and turn the ATC_RAT_YAW_VFF down a bit.

Chris . . . it’s me again, LOL
Do you think I’d have any luck or just spin my wheels, plugging these values into Mission Planner and deleting all other values, assuming I don’t want to run a Mission?

I PR’d that param file to master for Copter 3.6 for Mission Planner. It should be in the frame params dropdown list in MP to load into a heli with Copter 3.6 in it. Regardless of whether or not it is the correct tune, I would highly recommend loading it anyway and then tweak from there. It does not set up the swashplate, pitch ranges, servo limits, etc… It just tunes the attitude, rate, position and nav controllers specific to helicopters.

4 posts were split to a new topic: JCZK Heli and MiniPix

Chris,
I am no expert–but. I have a JCZK helicopter. That’s what got me into the Minipix.
The JCZK works exactly as shipped and with the Radiolink AT9S transmitter. It took me some time to learn how to arm it. It has a Minipix but in a unique JCZK plastic box.
Mine flies very nicely in stability mode, good position hold, good RTL. It came with NO instructions of any kind. Shame on the vendors involved. Although it uses all Radiolink products, Radiolink does not support it, per se.
Channel 8 is the motor on-off switch. Channel 5 selects stability, position hold or hover. Then the switch in the far left corner, over rides the Channel 5 selector switch to command RTL. For take off, select stability mode.
Arming is full right rudder at low throttle. A blue light on the Minipix means it is searching for GPS. A flashing green light means it has found some GPS. When the green light stays on it has acquired enough satellites for a GPS fix., put the motor on-off switch up and advance the throttle. It spins up to full rpm at about half throttle stick position. Then lifts off with more throttle position.
I copied the parameter files to my computer for future use.
The transmitter is setup in the quadcopter mode–NOT helicopter. This is because all the mixing between channel 3 and 6 is handled inside the Minipix.
I hope this helps someone!
Ed

Servers by jDrones