Help Setting Up Traditional Helicopter

EDIT: Starting reprogramming from scratch.

Did you go through the setup pages?

I may have to, because it’s a clone heli and was apparently preconfigured as a quadcopter. It was supposed to be RTF right out of the box.
EDIT: Yes, went thru heli pages.

Yeah, that wont work. I recommend reading through the whole trad-heli documentation.

It looks to me like you got channel 8 reversed in the RC? So it’s putting out full throttle signal with the throttle hold on? That won’t even let the ESC arm in the heli. So it’s not going to arm due to “motor interlock” error, and if it did it would go to full throttle.

You’re probably right Chris . . .
EDIT: Changed to Throttle Curve option in MP.

It’s impossible to tell from here what they have done there. It looks they tried to sell a pre-configured RTF model and really whacked some things up. But if it’s able to be set up using normal ArduPilot setup it will work.

I’m staying with it . . . the model itself is impressive . . . any setup suggestions you can offer outside of Ardupilot will be noted.

btw, all the documentation I read on Pixhawk suggested “mounting the Pixhawk with the arrow pointing towards the front of the craft” . . . this heli has it mounted with the arrow towards the rear, facing the GPS
EDIT: Thanks Chris . . . changed COMPASS_ORIENT to 4: Yaw 180

Okay, it’s me again, went thru the Arducopter setup pages and nothing changed, unable to Arm. The supplier sent me all the pics of his Tx display and here they are along with the Params file from Mission Planner.
Anything that stands out that might be an issue, please respond. New to Copter but I’m hoping maybe some of the settings on this Tx might be common to other brands.


210PARAMS.param (12.9 KB)
About the only way I can get the Flight Controller’s Blue and Green LEDs to come on is to Disable ARMING_CHECKS completely.

Set your Frame_class parameter. For trad heli it should be 6. I think that would be a big problem as to why it is not arming.

Edit: looks like you need to calibrate your accelerometers and your RC controller. You don’t have any H_ parameters. Hopefully they will show once you set the frame_class to 6. If not then you don’t have a heli firmware loaded.

I’m wondering about that too. Right here, I don’t see how they can get the system to arm without a “motor interlock” error. Channel 8 has to be at 1000 pwm to get the ESC to initialize, and the FC to arm.


Right now it is in an undefined frame class. I don’t know what it thinks it is but it doesn’t think it a heli so I would imagine it doesn’t care about the channel 8 input.

OK, yeah. I had missed the link to a param file there to look at. No heli params in the file. That would definitely do it.

I have no idea why the manufacturer chose the transmitter setup using Quadcopter parameters and not Helicopter parameters. I tried both ways with no success and the Helicopter params are more in depth. Tried going thru the Arducopter setup with no success. The manufacturer refuses to give me the param file it was shipped with and unfortunately I did not retain a copy before I set them back to what was Default in Mission Planner (didn’t think I’d have to). I know it’s a cloned MiniPixhawk but it’s not like I’m asking for a source code.
This is the RadioLink cloned Mission Planner if you care to take a look (slow download):

I’m sure the problem I’m having must have a simple solution but I’m not far enough up the learning curve to see it.

I’ll try your suggestions, as well as Chris’ . . .
For now, as an fyi, they have Ch8 mapped to SwA for Throttle Enable/Disable(maybe a safety thing?) and Ch5 mapped to a 3-pos SwG for Stabilize, Position Hold, and Hover.

Okay guys, here’s the conclusion I’ve come to . . .
BRAND-X buys off the shelf transmitters, receivers and GPS modules from RadioLink.
BRAND-X then programs them to operate with their helicopters’ cloned MiniPixhawk.
So if you Reset parameters of the Flight Board to Default using Mission Planner, you really don’t know what you are Defaulting to.
Now BRAND-X will not give you the original param file (even though you just purchased their product) but requests that you get it from another customer of theirs. WTH?

That being said, what do you think would be the minimum number of parameters using Arducopter, (if I can get the Flight Board to accept them) to possibly get this bird in the air? I’m all calibrated and ready.

Throw their mission planner away and use the standard mission planner from Ardupilot or use qground control. Install the Heli firmware and start configuring your aircraft per the trad Heli set up wiki. It’s not worth wasting your time trying to get this to work with their software
Just my opinion.

1 Like

@bnsgeyer It might not be that clear. We don’t know even if the FC is fully compatible with ArduPilot, or if needs a custom version and also the custom MP. It really is a box of unknowns, so although we would like to get @JEFFGORDON flying with TradHeli it might prove very hard.

I think I would give a try though. Try using one of the open source ground stations and load the official ArduPilot heli release in it and see what it does. If it bricks it it’s only a $35 unit, but I’m guessing unless they changed the boot loader it should work. I highly doubt these guys have the engineering resources to design something else on the hardware side that would be incompatible with PX4. I think they more modified Mission Planner to “dumb it down” a bit as far as settings but under the hood it’s probably ArduPilot compatible.

@JEFFGORDON I’m assuming this aircraft came configured with the miniPixhawk and transmitter as a RTF kit.

Sounds like this is the OEMs mistake. their quality control is not that good and sent it out without the controller being configured properly. If that is indeed the case, then I would send it back as defective and have them send you a new one. If I got an RTF aircraft and it didn’t fly properly or at all after following their instructions, then I would send it back and tell them to fix it or give me one that works as promised.

Again just my opinion.