[HELP] Setting up radio CRSF

Hey ya’ll, I’m using a matek F765 with crossfire and I’m struggling to get my crossfire nano to show up on the receiver calibration tab. I’ve tried using SBUS, Mavlink Tx and Rx, CRSF and DSMX and I’m lost about what to do.

I only use crossfire with mavlink on ArduPilot, and don’t have any issues, is the nano set up correctly, I normally run at 100mW and dynamic, telem on and rc by mavlink on. Which outputs are you connected to and is the usart/serial port set to 1 and 57600?

1 Like

I’ve desoldered everything. I think I had my nano going Tx-Rx and Rx-Tx on UART 6 beforehand though.
I’ve watched Painless360’s video on setting up the radio and when he had his receiver disconnected the radio calibration was all on 0. Here’s a picture of mine with no receiver connected. I’m not sure how to set the UART/serial port to 1 and 57600 though

Is this correct for the crossfire nano?
Also should the setting for it be CRSF Tx and Rx
Tx by Mavlink and Rx by mavlink?

you want to set your NanoRx’s pins to CRFS TX / RX and the UART it is connected to SERIALn_PROTOCOL = 23 RCIN. ardupilot will auto-set the baud rate correctly iirc.
please check https://ardupilot.org/plane/docs/common-matekf765-wing.html#default-uart-order for your respective board’s UART / SERIAL conversion table.
USART6 (=SERIAL 7) requires additional attention and setting BRD_ALT_CONFIG correctly to have both RX and TX available.

1 Like

Did you get this sorted? I’ve got same issues. I’m running crossfire to uart 6…so would I set SERIAL6_PROTOCOL = 23 ?

Yes, you need to set it to 23. Edit: I should expand on this. I you want to use Yaapu telemetry then you’ll need to be running 4.1.dev. Have a read of this thread:

Hmm this didn’t work for me.

I have UART 6 with crossfire but as per the default UART order for F765, i changed SERIAL7_PROTOCOL = 23. But still no RC inputs. Just telemetry.

What version of plane are you running? What board are you using?

Following on this thread. I am having the same issue in Copter v.4.0.7

You need to use CRSF protocol for RCIN (SERIAL_PROTOCOL=23) and enable custom CRSF telemetry with RC_OPTIONS+=256 (add 256 to your current RC_OPTIONS value).

If you want to use the Yaapu telemetry you’ll need to use the latest 4.1.dev.

I had Kakute H7 and cant display telemetry in my taranis x7 too. I had set all mention in h7 procedures set serial protocol to 23 brd alt cfg 1 but when i saw telemetry page in taranis it shows only asterisk :eight_spoked_asterisk: it means telemetry link between h7 ardu board and my taranis is not valid.

Pls help for the solution