Servers by jDrones

[HELP] Setting up radio CRSF

Hey ya’ll, I’m using a matek F765 with crossfire and I’m struggling to get my crossfire nano to show up on the receiver calibration tab. I’ve tried using SBUS, Mavlink Tx and Rx, CRSF and DSMX and I’m lost about what to do.

I only use crossfire with mavlink on ArduPilot, and don’t have any issues, is the nano set up correctly, I normally run at 100mW and dynamic, telem on and rc by mavlink on. Which outputs are you connected to and is the usart/serial port set to 1 and 57600?

I’ve desoldered everything. I think I had my nano going Tx-Rx and Rx-Tx on UART 6 beforehand though.
I’ve watched Painless360’s video on setting up the radio and when he had his receiver disconnected the radio calibration was all on 0. Here’s a picture of mine with no receiver connected. I’m not sure how to set the UART/serial port to 1 and 57600 though


Is this correct for the crossfire nano?
Also should the setting for it be CRSF Tx and Rx
SBUS
DSMX
Tx by Mavlink and Rx by mavlink?

you want to set your NanoRx’s pins to CRFS TX / RX and the UART it is connected to SERIALn_PROTOCOL = 23 RCIN. ardupilot will auto-set the baud rate correctly iirc.
please check https://ardupilot.org/plane/docs/common-matekf765-wing.html#default-uart-order for your respective board’s UART / SERIAL conversion table.
USART6 (=SERIAL 7) requires additional attention and setting BRD_ALT_CONFIG correctly to have both RX and TX available.

1 Like
Servers by jDrones