Help required: change in log-settings and in building with waf

Dear ArduPilot Community,

this is my first post with a more or less difficult subject, where I hope to have a) selected the right category and b) given as much details you need for helping me in this case.

My goal:
I want to adjust/change settings for the logging of flight data for my Holybro PX4 2.4.6. ArduCopter. The Flight controller is installed on a Tarot hexacopter frame.
By using MissionPlanner I was able to adjust a lot of information to be logged and also their specific frequency, e.g. IMU logged as RAW (resulting in giving me ACC1, ACC2, GYR1, GYR2 in 1000Hz). I now want to adjust other IDs/values like RCOU, CTUN, etc. to specific frequencies. I want to adjust e.g. CTUN to 50Hz and RCOU to 400Hz.

My proceeding - Change in log-settings:
I found out, that it might be possible to change logging frequency within the file “ArduCopter.cpp”.
Therefore I changed the code, in that way that e.g. “MASK_LOG_RCOUT” is now put under the 400Hz main loop within “ArduCopter.cpp”. I hope logging will be then triggered with 400Hz to fulfill my above stated request.
I am not sure whether or not this is working. If you have another solution I am grateful for any help.

My proceeding - Building the ArduCopter Version with waf
To test whether or not this is working, I wanted to build the code with waf - as mentioned on the ArduPilot wiki:
Therefore I followed the instructions on the page:

  1. I downloaded GitHub and cloned the files to Desktop (master branch of the current ArduPilot)

  2. I started Git Bash and inserted “git config --global core.autocrlf false” - but there was no feedback of success or failure, also repeated the command when I changed to the local Git-Dir on my HDD, in this case “C:\PX4\ardupilot”

  3. I also used Git Bash and entered “git submodule update --init --recursive” - a lot of failure modes arised
    Failure tells “failed to recurse into submodule path ‘modules/PX4Firmware’”

  4. Since I assume I did everything for the GitHub, i switched to the PX4Console, and navigated the root to my cloned Git by entering “cd /c/PX4/ardupilot/”

  5. In PX4console I then ran “git submodule init” and also bind the command waf with “alias waf=”$PWD/modules/waf/waf-light", because otherwise, the commands “./waf” and “waf” are not found

  6. I tested functionality with the command “waf list_boards” and it works by giving me back the list of boards

  7. I tried to run “waf configure --board px4-v2”. Error message is arising:

  8. Also for “waf configure” there is this error, stating that the msvc compiler and the library rt is not found:

I tried a lot to fix this, but since I am no programmer, I actually don’t know where to look and how to solve this issue.

Further information of my setup:
Windows 7 (64bit), using latest versions of GitHub Desktop, Git 2.13.0, and downloaded Pixhawk Toolchain on June 8th 2017, installation root for PX4Toolchain: “C:\pixhawk_toolchain”
No further libraries installed (Python, Java, C++)

I did in one try install Python 2.7, Python 3.6 and also MS Visual Studio 2015 & 2017 with all runtime libraries but this didn’t help as well.

Thanks for the help,