Help needed to tune a flybar 600 nitro heli


I have setup a PH2.1 on FW 3.5.7 on a Raptor 50 (600 size) nitro helicopter. I have setup the heli exactly as per Chris Olson’s four videos in the Ardupilot docs. (Thank you so much for the videos sir, if not for the vids i would’nt have attempted). I’ve been flying helis for a long time and can fly in manual mode(acro).

As it was a flybar heli, and as the docs and i read here, i got the rate PID all set to zero and put the VFF for P&R to .22 and ATC_ACCEL_MAX P&R to 72000. The heli is stabilizing but too very restrictive and too quirky. When given sharp pitch inputs the heli over shoots when stabilizing. I tried reducing the vff of pitch to .15 but the heli still bounce while the stabilizing (not oscillating). The roll is okay but is too quick.
I also tried alt hold and seems to be doing well. When in FF flight of around 10-15 m/s the altitude is in the range of +/- 1mt.

All my log files are of full 15mins flight and is around 17mb each. Will make a shorter flight tomorrow and post a log file soon here.
This is the first time i’m working on the PH and heli need help in going further. How do i dampen the stabilization and make it softer? should i tune the D value or something else?
After i get the VFF right, i put the vff value to the rate ‘i’.
What about the D? after all the above should my P & D will stay in zero?
What is the acceptable vibrations level in PH2.1.

Thanks in advance.


Do you have idea of what your headspeed is? Flybar helicopters from 3D world are set up with really lightweight flybar paddles and seem to like a lot of rpm to be stable. Or they tend to “tail bob” in the pitch axis. Trex flybars are the same as the Raptors in this regard.

The autopilot tends to react against the flybar instead of letting the flybar do it’s job. Set your VFF’s back to .22 (minimum), fly it in Acro and see if it still does that “tail bobbing”. If it goes away in Acro (direct thru control with flybar) then it is the autopilot causing it and we’ll have to try to tune that out with the low pass filter.

If it stil “tail bobs” in Acro then we got either headspeed too low, or flybar paddles too light.


I am not using a governor on it yet, but I know for sure that the head speed I’m flying is around 1700 atleast, which is sufficient, actually 1500 should be good enough, but it’s definitely 1700 or more. That’s for sure.
The fly bar paddles is the stock plastic flybar paddles from TT Raptor, the plastic ones which are slightly more heavier than the carbon ones.
I don’t think this is happening in acro mode, will do a short flight now and check thou.

Here’s a small hovering video in stabilized mode.

Try setting the pitch low pass filter lower (ATC_RAT_PITCH_FILT). You can go as low as 4Hz. See if that makes a difference.

It would be best if you posted a param file for us to look at. If you are seeing a pitch bounce, most likely changing the filter setting down to 4 Hz will not help. In my experience the frequency of this behavior is around 3 Hz or lower. I think the best thing to do in this case is to increase the weight in your fly ball paddles

In the past I’ve been able to set that down to 4Hz and get it to stop, but only on bigger ones. Smaller flybar helicopters tend to keep wanting to do that. But they won’t normally do it in Acro.

So my theory is that it’s caused by the stabilization system not letting the flybar do its job. When you nudge the stick quickly and center it the stabilization system tries to level it again right way. And then the flybar does one thing while the stabilization does the opposite for a few bounces until it goes back into equilibrium.

Increasing the weight of the flybar paddles certainly helps because it reduces how fast the flybar responds. But then if you want to fly the helicopter in Acro for fun it’s a little sluggish.

Another thing I found over time is that shifting the CG helps. My old 700 flybar with the fuel tank full (aft CG) was fine. But if the tank got empty it exhibits a little “tail bounce”

So my setup for flybars is different. For the FBL I prefer to use Stabilize for the manual flying mode, for flybars I still prefer Acro. They are fine in Loiter or Auto where the control inputs are slower. They only do it in Stabilize where you can make quick control inputs and the mechanical stabilizer seems to interact with the electronic one.

Oh, I forgot to mention another “trick” I have used with flybars - set the paddles to about 1 degree of positive pitch instead of running them flat. That also slows the flybar down a little. Use your digital pitch gauge if you do that, though. Because they have to aerodynamically balanced or it will make the head wobble.

Easiest way to add weight to the paddles is to unscrew them from the flybar and put a couple stainless steel nuts on the flybar rod. Or some use lead fishing sinkers. Some flybar paddles have holes that you can put lead shot in to add weight.

Please see my param file attached here.

13-10-18.param (13.7 KB)

Will try the filter in the morning. my present default value is for the pitch filter is 20.
Also attaching my log file. In This flight my muffler was loose and the engine was going wild with the head speed, i was going on reducing the RSC Low to keep the head speed in range. so you may see more vibration in this flight.
Just fixed the engine/muffler, tomorrow will do a fight and post the log file.

Thanks for all the help everyone.


PS: oops the file dint upload, Its a 9mb file.

So the RC_FEEL is low which is good because it slows down the time it takes to get to an attitude. You do need to have some I gain for both pitch and roll. This will help the system maintain attitude better. I would think you would want them to be 0.2.

I was just comparing the paddles weight, The paddles i have on the heli are the heaviest, these are the stock raptor 50 black paddles. Its around 27gms. Is it safe to add more weight to the flybar?
The other CF paddles for 600 size helis are in the range of 14gms.

  1. i will introduce I gains as same as the vff
  2. Will set the paddles to about 1deg positive pitch.
    if the above dosent work then:
  3. Will reduce the low pass filter till 4hz (presently 20hz)
    Thanks for all the inputs.


Yes, you can add weight to the flybar. I’ve done it on all my UAV flybars. I usually put stainless steel nuts on the bar


Thankyou Chris, will add some weight on the paddles.
Also wanted to ask, after tuning the vff and introducing i, Will the P & D still remain zero value forever?
ATC_ANG_P is 4.5, will this need to be tuned?
ATC Accel Max is in 72000 now, is this value okay for a 600 size heli? or should this be further reduced?


Yes P and D will remain zero when using a flybar. I want to add that with adding I gain, you want to change ILMI to 0.05. This will allow the buildup of a little attitude stabilization in a hover. Basically allowing the I gain to work in a hover. [quote=“Adi_Fly, post:15, topic:33964”]
ATC_ANG_P is 4.5, will this need to be tuned?
You could try making this 2.5 for the pitch axis to see if it helps with the pitch bounce. If it still persists after adding weight to the paddles.

Added weights to the flybar.

Thank you Bill Geyer and Chris Olson.

I did all the above what is told one by one.
ATC_ANG_P reduced to 2.5
Added ILMI to .5
Reduced Low Pass Filter to 5hz
Added i gains of .22
The pitch bob is reduced to a large extent but not totally gone.
Here’s my parameter file and my log file. For some reason the log file is not getting uploaded. How do i upload the log file? its 3.25Mb file.


14-10-18.param (13.7 KB)

I would try ramping up the headspeed slightly to see if it goes away. Another experiment you can do is offload the CG a bit by adding some rear weight to make it tail heavy and see if it goes away.

The sad fact is that most of these 3D helicopters are designed to be so quick that they don’t like being flown in a de-tuned state sometimes.

I tried ramping up the head speed but no luck. Still the same.
Will try getting a aft cg and try tomorrow.

Also, I will be trying the loiter and position hold tomorrow. My altitude hold is doing fine.
Which is a safe mode to fly around? the loiter or the pos hold? As these both uses Gps.

In one of the threads I also read that it’s advisable to change the Ek2 Imu mask to 1 for Gps used modes. Should I do this?

Today I observed the MP gave me “bad gyro health” and “Gps glitch” error messages. What should I do for these errors?

Thanks for all the help.