HELP! Drone going right in AUTO mode Almost lost quad

I’m Using 4.0.6 release and when I’m doing missions it just goes like it follows a spline waypoint and instead of going directly to the waypoint it makes a curve and misses the waypoint here are the videos and log and the plan files for investigation

Please update to ArduCopter 4.1.0-beta8 and retry. Your parameters are preserved when you update the firmware, so you can fly right after doing the update.

WARNING: When downgrading that is NOT the case. there you are responsible for restoring your old parameter values from a backup.

I had a great test with 4.1.0 BETA8 But something is off when taking off. I need a solution for that. With the same parameters, I could take off easily when I was using 4.0.6

Do you have a log you can upload of the beta8 take off problem?

also just so the devs can find it easier, maybe post it also to the 4.1 beta8 thread? Copter-4.1.0-beta8 released for beta testing

Do you have HOVER_THR_LEARN set to 2 like it should?

Yes here it is also yes I have that parameter set to 2

What’s the problem? You took off in Loiter and switched to Auto when it was ~6m.

Yes Indeed I took off but it was not stable after the software upgrade like the quad threw itself front first a bit and then it took off

Accelerometer calibration? Looks like there was a ~6deg bias on take-off. Of course the ground may not have been level.

Okay than I will calibrate accelerometer again ground was level. By the way what do you think about the tuning of this Quad. And also logging is broken I changed the SD Card and formatted it but it did not work. I actually need an urgent info on this logging problem @dkemxr

The Logging thing is crucial I need help ASAP Quad is flying again well but logging is the main problem rn

Yup I finally had my tests. Here is the .bin file it is oscillating somehow . @dkemxr @amilcarlucas But somehow and luckily takeoff problems are resolved
Here is the link to the video and the bin file:

That folder is empty

Could you please re-check I reuploaded @amilcarlucas

I don’t know where you came with this but set it back to default (20).

Then manually tune it. Or set aggression to default (.1) and Auto Tune.

1 Like

Do you think quad is safe for autotune right now ?

as you can see here that INS_ACCEL_FILTER is10Hz

Connect to MissionPlanner and press Alt A to run the initial parameters plug-in and correct any values.
Or use the spreadsheet linked below. They are derived from the Tuning guide and Leonard Halls actual flight data and experience.

No. Set the accel filter to default.

I actually tuned my quad according to this spreadsheet but the tuning guide in the wiki said 10 so I just changed that parameter

Some interesting results here. After I autotuned values changed dramatically. But it is flying well actually. Just one problem drone is oscillating when it is not moving in LOITER mode could you guys please check this out @dkemxr @xfacta @amilcarlucas