Servers by jDrones

Helicopter failed to use H_SV_MAN to set Collective Pitch Range and Zero Thrust Point

accrrding to the doc [https://ardupilot.org/copter/docs/traditional-helicopter-swashplate-setup.html?highlight=h_sv_man](http://Traditional Helicopter – Swashplate Setup).
i followed the steps in the doc.Actually the Collective Pitch Range is not the same as the value I need.
these are my steps.
1 set H_SV_MAN to 1.adjust the trim of each channel.
2 set H_SV_MAN to 2. Adjust H_COL_MAX until collective pitch angle mesures 12°.
3 set H_SV_MAN to 4. Adjust H_COL_MIN until collective pitch angle mesures -2°.
4 set H_SV_MAN to 3. Adjust H_COL_MID until collective pitch angle mesures 0°.
finally ,i set H_SV_MAN to 0 and push the throttle stick to max, the collective pitch angle is 10° .push to minimal, the collective pitch angle is -1 °.
could any tell me where i did wrong?

What flight mode were you in when you did your check? Acro will provide the full range. If you were in stabilize then you need to look at your IM_STAB_COL settings. If IM_STAB_COL_1 is not 0 and IM_STAB_COL_4 is not 1000 then you will not see the full collective range.

Problem solved, thanks for your help.

Did nothing wrong at all. In manual mode the PID loop is bypassed and so is the attitude controller attempting to level the swashplate. Once you switch out of the manual mode the PID loop is active again and damps the control inputs, the attitude controller is active again attempting to level the swashplate, and what you see on the bench is not what you’ll get in the air.

That’s why the manual mode is provided to set the pitch ranges.

Servers by jDrones