Has anybody managed to get QGroundControl GCS working on RPi?

I am desperately trying to have QGC working on my RPi 3
I tried to install it on the lastest Ubuntu Mate (should have been ok…)
I tried to recompile it from Raspbian Jessie, but impossible to install the proper version of QT (need 5.5.1 and could only install 5.3.2)

I am now blocked!!

Best case would be that someone just tells me where to download a ready disk image integrated Raspbian + QGC! :wink:
Or at least some idea to overcome this situation

Thanks in advance

Hi! Did you find the disk image for Raspbian + QGC ? I am trying to do the same as you,




I have got QGroundControl to run on Rpi3 with RT Android on the Rpi =) I have just done a bench test. Seems to work good


Hi! I ll be glad to see it working!
Could you have any mean to send out a disk image? (E.g. via mega)
Thanks guillaume

I’ll try to do a quick writeup om how i did IT when I get back to my notes later tonight.



Just follow the simple steps on : https://rtandroid.embedded.rwth-aachen.de/downloads/raspberry-pi/

I did it and it works good!


1 Like

Thanks very much i ll do that

@Guiboy sorry for not following up on this… Did you get it to work?

Hi! thanks very much for the info, I just could not take the time to look after it this week, but will be interested in the coming days. What I would indeed be more interested about is the possibility to run QGroundcontrol in a linux raspbian environnment in order to run wifibroadcast in the same time
This would allow having a GCS customized to my own user need as well as extending the range of my wifi video streaming. I fear that if I go to android, I may probably not succeed to make wifibroadcast work…


I’ve tried getting it to work under Ubuntu MATE on a Rpi3. I gave up after i found the Android solution.
It would be really great to have Qgcs working under Linux on a Rpi. I will give it a new go when I can find some time.



I have begun trying to get Qgcs working under linux on Rpi 3 again. I’ve started with a fresh install of Raspbian Stretch. Currently the box is compiling Qt5.7.1 and Qt Creator. Hopefully I can try to build Qgcs later tonight. I will post back with the results.


Have you tried qtrpi.com?

how exciting!!! Looking forward to see if it works… it goes beyond my skills…
Thanks for sharing the experience


I’ve seen it! But it does not support Qt 5.7.1 as Qgroundcontrol requires. :worried:

It’s sort of beyond my skills also… Learning by burning… :joy:


This is giving me a real headache… Still trying to solve the issues =)


@Guiboy long time no see. I finally got some time to work on this project again.
I can now start the QGC on my RPi3 under Raspbian Strech.

The system runs without X and is really fast. I haven’t connected to my APM yet, I need to cleanup some stuff and then I can make a working image if you are still interested.


Alex you are my god!
How did you come to make it work in the end? I had the feeling this was “mission impossible” after starting it and seeing so many bugs in the former trial.
Yes, I am of course more than interested.
I would like to use the RPi to run wifibroadcast in parallel of QGC.
This would allow long range 433 MHz telemetry as well as long range 2,4GHz video analogic streaming, the overall being packed into a customized GCS tablet.
Well, at least this is my dream…
I am looking forward to check it out, if you can share your disk image :slight_smile:


After reading numerous QT Raspberry tutorials i finally found a solution that worked…
But there are some issues… I’m trying to sort them out now… Yes I’ll share the image when I have a more working solution.


Maybe a write up of notes to get it going is in order. :slight_smile:

Could you share your recipe for building qt? I tried but gave up as life is too short: