Has any body set up an APM Rover system on a boat?

I am looking at setting up the APM rover system on a boat and was wondering if anyone has already had success with this? my main concern is the accuracy of the system and if it will be able to operate the boat along survey lines?

Look here: diydrones.com/forum/topics/a … evelopment
Also try doing a search on Google, as the DIY Drones Discussion Forum search engine does not work, as there have been several more members on DIY Drones that have autonomous boat projects.
TCIII ArudRover2 Developer

I think nobody had real success with arduboat.
Even with the last APM.
I tried to find a program on several forums, but all I can find is non or bad-working ones !
Arducopter seems to works fine, but I can’t use it for a boat, so it is waiting in its box…

Thought I would chip in. I have been having a lot of success with an APM boat. Running an APM 2.5, and the most recent firmware, the 36 inch hull runs around our lake very well, maintaining about 4 knots on a 2830 brushless with 2 x 3 cell 5 Ah Lipo, giving about 2 hour continuous runtime. Telemetry is used, and the info given on the laptop display in the clubroom is excellent.

Since a mishap is not too expensive ( usually runs into bank or a buoy), I have been able to set up as many as 16 waypoints, using either routes either from sailing the course I want and pressing the record, or pre planning from the pre-fetch map.

Only problems noted are the occasional wider sweep than normal around a buoy, or an overshoot of the waypoint by a few yards.

At 36" the hull is a bit too large for convenience, and I am building a 20" launch, using the same gear, and hopefully carrying an FPV type camera. I just hope everything will fit without undo rf interference problems.

So don’t give up, the system does work, and works well (for me anyway).



Which program are you using for your boat ?
May be you have a link for a working program ?


Sorry for the delay in replying,. busy building the replacement boat, almost done. I have now flagged to be notified when a reply is posted, forgot it initially.

I am using 2.45, on an apm 2.5 board. It works fine, other than the very minor problems I mentioned on the initial post.

There is one other guy at the club, using the same setup, and his runs just as well.

I have scrapped the old hull I was using, and am just putting the final touches to the new 20 inch boat. The kit has been part tested in sections for fitting, and looks good. But it is a bit of a squeeze. I am aiming for about a 4 amp current draw, much as I had on the larger hull, using a 2830 brushless but only one 5 Ah pack. Unfortunately there will be an additional drain for the FPV when fitted, but I may well add remote on- off for that.

Initial tests will be with no FPV fitted, to confirm the telemetry works ok in close proximity to the receiver.

The old hull was very stable and I could operate in any weather, wind, hail and rain, ( not ice of course).

The stability of the new hull is unknown, so it may cause excessive camera movement in rough conditions, not the end of the world, there is just room for a gimbal.Hope to have the new boat in the water in a week or two.
Enough about this end, what are you using there?


APM will be used on this boat:
During the last trial I burnt the 3.3V regulator. Did not know you must not plug receiver while only USB plugged in !
After replacing it is ready for a new test. Fire hose ready…

@George: Any photograph of your boat ?

I looked at the utube reference you gave me, that is certainly some boat. It turns beautifully on the spot. I noted the two motors. Are you trying to control two separate motors via the APM?

I have only used a single motor in a boat, but I do know there is some reference in the rover forum regarding dual drive, presumably for track vehicles. It may work. but then no separate steering would be required.

Mine is finished, but as always there is a snag, the gps will not get a lock. So it will go out in the garden tomorrow, hopefully it will work there.

No photos yet, been spending all the time getting the bits to fit in the hull, at 51 cm it was tricky. I’ll have a go at getting some tomorrow when it is outside.



If a model boat has both port and starboard motors/propellers then the ArduRover2 skid (differential) steering may be used to steer the model without the use of a rudder.
TCIII ArduRover2 Developer

Yes, there is two motors (Zenoah 38cc) but they do not need to be controlled separately for waypoint use.

To get a good GPS lock you need to be outside without any building around.
If GPS info is not accurate enough the track will certainly be erratic.

Before I take my rover out to the test track, I always run a satellite acquisition indoors to be sure I will have good GPS heading formation. I can get from 8 - 10 sats indoors with an HDOP of less than 2 here in Southern Florida in about 15 minutes.
TCIII ArduRover2 Developer

Pretty good for sats in your country, but here in France you really need to go outside.
Even in the garden I get no more than 5 sats. I have to go out of the town to get more than 8 sats !
It may be the reason for erratic movements of steering servo when testing in the garden.


Thanks for the prompt. I remember reading that bit, but as I only have single motor surface craft, I left it.


Yes, I overlooked the idea of running both motors on the one channel. In which case I wonder why you had problems with the APM, unless a small amount of ignition noise is sneaking in somewhere. There’s no doubt that the system does work, there are two of us at the local club, operating with virtually no problems.

Having said that, I have yet to try the new mini-boat in the water, the lack of room seems worse than in my U boat, and that’s tight.

The Gps eventually logged on. The fact that it had not been used for several weeks may be have been part of the problem, and also my workshop window has a metal strip blind across it. Tried today in the garden, with model on a plastic trash bin, and for a while got 8 sats. At the club, on the lake, I usually have 10 showing, so we are not to bad here. I am surrounded here by other houses, for that reason, when I am checking my Hexa in the garden, I have it on a long tether, as the hover seems a bit erratic. This may perhaps be due to path reflections from the other houses. Its rock solid at the local flying field.

I’d be interested to hear some details of the problems you had with the APM, any I did have were mainly self generated.



I did not have the APM mounted in the boat yet, it is just on a plastic board for tests. So no problem with motors.
As soon as I see the sun again I will test the AMP during a walk, taking the direction given by the steering servo from a waypoint to another.


Good idea to try it that way, but having used the system in a hexa initially, basic control only, I rested it for a while, then put it into a very battered old boat hull. The only home test was to ensure the rudder turned in the correct direction to a single waypoint when switched to the auto mode.

On the lake I ran the boat around the buoys and selected the waypoints as I wanted. even using one some 200 meters away. I used the ‘prefetch’ to put a map of the lake in the laptop, as we have no internet access there, and that works fine.

It took a while to get the hang of checking the list of waypoints, and getting the various parameters about right. It wasn’t long before I could send it off to play by itself while I viewed through the clubroom window as it went round the 15 waypoint course 5 or 6 times before the Jump kicked in and it came back into harbour and shut down before coasting to a halt at the jetty side. Admittedly it would bump the jetty a bit, but it was an old hull anyway.

I ran the thing for about 4 months this way before deciding to upgrade to the newer, smaller hull.

So all in all I am pleased with the performance of the APM, it remains to be seen how well the new hull copes with the load and the cramped installation.



I need your help. I have a rc boat 65cm. with 2 motors +1 servo. I am about to install apm2.8 . Which is the step by step installation process. In order to have RTL etc (I ‘ ve bought gps + compass +telemetry) Thank you in advance . Yours sincerely
Dimitrios Vrax

The 1st thing you should do is to replace the APM 2.8 with a Flight Controller that will run the latest firmware version of Ardurover. That Flight Controller is obsolete and you will be missing many features and will not get the same level of assistance. After you have done that follow the Wiki:

Dear George
I need your help. I have a rc boat 65cm. with 2 motors +1 servo. I am about to install apm2.8 . Which is the step by step installation process. In order to have RTL etc (I ‘ ve bought gps + compass +telemetry) Thank you in advance . Yours sincerely
Dimitrios Vrax

Posting the same message in multiple threads is bad practice. You have replied to a thread that is 6 years old here.

No kidding. You will be limited to Rover 2.5 I think. Really my opinion is you are wasting your time with a 2.8.