Harmonic Notch Filter

Hi… I face a really problem with my large copter. It s not stability and Oscillating in gps modes (loiter/ Auto and RTL). Know I m reading about works in double harmonic notch. So I want ask if anyone can send the PR to me and if the answer Yes how I can use it… Thanks a lot for any helping

please do a test flight with log_bitmask = 196607 and send bin log file for a better analysis
most of the times oscillation could because of high gyro noise , too high p term (if oscillation is slow) or too high d term if (if oscillation is fast) but totally its hard to say without a log file

Hi Hosein… Ok I’ll do a test flight with log_bitmask and share it in few days next… Thanke you very much for your helping

1 Like

Hi, I wanted some clarification on the procedure to obtain the FFTs and then apply the hrmonic notch filter.
after having done all the procedure of: ins_log_bat_mask, 1
ins_log_bat_opt, 0 … hover test in altold for a few minutes … from data flash log downloaded the bin file … and then ctrl F … and then selected FFT … a mask appears that it shows me 5 green cards at the bottom … 1) IMU BATCH SAMPLE … if I follow this path it asks me to open the bin file but then it doesn’t show me anything … 2) RUN ALL IMUS- IMU1- 3 MSG some strange graphs appear to me … 3) RUN ALL IMUS- ACC GYR MSG … here I see the graphs of ACC1 and ACC2 as well as GYR1 and GYR2 … 4) WINDOW … RUN LOG-IMU 1 ACC1 GYR1 MSG here appear 3 windows for GYR1 (xyz) and 3 windows for ACC1 (xyz) … then there is a 5 window. … RUN 16 BIT MONO WAV …
Now I ask … in the previous versions you went to the 1 window that reported NWE DF LOG … NOW IN THIS LATEST VERSION DVE YOU MUST GO … ON WHICH WINDOW ??? Maybe on the 4th window ??? because going to the first one asks me to appear the bin file but then nothing happens … nothing appears on the screen … going to the 4 window “RUN LOG-IMU 1 ACC1 GYR1 MSG” here yes I the above-mentioned windows appear but single not united in a single window the three axes … then again sometimes the frequency scale shown under the axis appears to me

IMU Batch Sample is the correct way to open the file. If there is nothing present then you probbaly didn’t configure correctly. Just attach the parameter file or a link to the log.

Hi thank you for your quick answer … I’m new in this field … would you explain to me how to activate that …Imu batch sample
Tks

Attaching your parameter file here would be a lot easier. I don’t need the log if you are worried about confidentiality just the parameter file.

hello … you want the file of the full parameter list … ??? … see if I can do it

Yes, from the Full Parameter List screen the “Save to File” button on the right.

Full Parameter List.param (17.6 KB)

Hello dkemxr,
I thank you for the help you are giving me … one thing I have to say … that since I frequent this forum I always follow your interventions which are a lesson for us beginners … you always learn new things and that few people explain to you … they teach you in a simple and feasible way for anyone … many thanks again …

You need to set INS_LOG_BAT_MASK to 1. Before you set the Dynamic Notch Filter you should set all the Initial Tuning Parameters from the Mission Planner Alt>A Tuning plug-in.

If you see my initial post above I have done that …
"Hi, I wanted some clarification on the procedure to obtain the FFTs and then apply the hrmonic notch filter.
after having done all the procedure of: ins_log_bat_mask, 1
ins_log_bat_opt, 0… hover test in altold for a few minutes… "

Finished working with the notch filter, I returned the value of ins_log_bat_mask, from 1 to the value 0 … as well as the value of ins_log_bat_opt from 0 after activating the notch filter and then brought it to the value of 2 to check the data post filter … and then bring it back to 0. I don’t know if I did everything right … I have some wrong passage that doesn’t make me use … the FFT IMU BATCH SAMPLE box work.

It’s not set in the parameter file you posted, look for yourself. You probably didn’t Save it after changed the parameter.

Thanks dkemxr,
i solved the above problem … now i was wondering

After setting automatic learning of Hover Throttle (previously known as “mid throttle”) The MOT_HOVER_LEARN which enables this function by setting it to the value 2 … and after using the value obtained also in applying the harmonic filter notch in the parameter INS_HNTCH_REF … I was wondering if the MOT_HOVER_LEARN parameter from the value 2 wants to be reset to 0 (disable) or it always wants to be active set to the value 2 (learn and save) ???

Always 2 learn and save unless you’ve got a special reason to do something else

Many thanks for the answer.