Hardware Safety Switch will not engage

I have a quad built with PH2 and most current version of Arducopter. Everything is great, but I can’t arm. The HARDWARE SAFETY SWITCH will not engage when pushed and turn solid red.


Have you done the short/long double push?

Just tried it. No change (Like a DJI double push?)

Is there a solution you found for this?

I have a HEX build with purchased Pixhawk 2.1 (Cube) last year and have never been able to arm. It’s been sitting through the cold season and I’m now back at it.
Updated to Ardrupilot ChiBiOS 3.6.9 and Mission Planner to the latest.
ESC calibration has never worked via "All At once’ or via Mission Planner Wizard

Pixhawk 2.1 (Cube) purchased April 2018 IRLOCK (Online)
30Amp Favorite LittleBee running BLHeli 32 with default settings
MOT_PWM_TYPE - I’ve tried Normal and OneShot125
It seems everything is good to go after powered-up, Steady Green Flash on GPS, pulsing Red lights on the button.
Pushing it does nothing. Try to arm and get Pre-arm Safety Switch…

How would I trace this down to the Hardware problems I’ve read about vs, software?

1 Like

I know it’s in the PH2 unit itself due to trying with many Here+ GPS units.

My methodology after last weeks research…

I feel its not a hardware issue with the HERE unit as seen by some. This due to all my LEDs and flashing patterns on GPS unit seems correct.

There are several New variables within this build so I have to approach them one at a time.
I’ve built two Quads previous however this is my first HEX. First using the newer Pixhawk 2.1 (Different company than original). First using BLHeli_32. First using ChiBiOS Port for Ardupilot. First using variant signaling i.e DShot…

If I disable the safety switch,BRD_SAFTYENABLE - 0 … I am able to control motors via Taranis… however, I feel the communication between PH2.1 and the ESCs is not operating properly… I’ve never been able to calibrate with any method.
(Maybe PH2.1 knows2019-06-02 21-25-37.tlog (835.1 KB)
this and won’t ARM)
Uploaded last nights TLOG while trying to ARM if anyone knows what to look for, or could give such direction.

Without any notice within Mission Planner messages, I’m not being told WHY nothing happens when I press the Safety Switch, So I am thinking some type of signaling is Not happening to the ESC’s

Currently I have my ESC’s plugged into MAIN 1 through 6…
Mission Planner is set using OneShot125
(Idea is to get this operating at a Basic level BEFORE moving to advanced DSHOT configuration etc…)

At this point should I go forward Moving the ESC’s to the AUX outputs and configure PH2.1 for DSHOT , SERVO_BLH_AUTO - 1 etc??

One Shot ESC’s usually have a PWM range that is manually input. No need for calibration. Check the manual.