H743 yaapu telemetry

Hi everyone. I need help with my adrupilot setup:

  • Matek H743
  • Frsky R9 SX
  • Frsky Taranis X9 lite with R9M lite pro

Probem is that I can not get telemetry on my remote. Setup on ardupilot:


I would like to run yaapu script on my remote. Any suggestions?

Hi Mark, have you solved your problem in the meantime ?
I have the same problem with very similar hardware:
Arduplane 4.07 using the same configuration as described by you.
Matek H743 Wing
Taranis x9d plus se 2019 with OpenTX 2.3.10, yaapu script is showing up but has no data
Taranis did not found new sensors after script installation
FrSky Archer RS using ACCESS, Fport and Fport2 enabled
Beside Ground and 5V I connected the SPort directly with RX6 as described elsewhere.
Servos are controllable with this wiring.
I have no idea what I am doing wrong.

I hope you Mark or someone else can help now…

Try TX6 instead of RX6.
I also had no luck with RX6.



What I did and it did work at the end is, that I just flashed FC with same firmware. Somehow if wored with same settings.

For some settings that I saved in Mission Planer were not working afterwards, but worked after I saved them with QGC.

I got GPS, artificial horizon and airspeed on the remote. But no message, voltage etc. At the end I switched to TX16S. It was just too many problems in general with remote.

Dear RainFly,

you saved my day :slight_smile:
I tried what you said and it looks like it works. Now Taranis can find the sensors after a fresh search and Telemetry-Screen shows several values.
Thanks so much for your help and also thanks to Mark for giving feedback!

For all pilots who have similar hardware:

  • Arduplane 4.07
  • Matek H743 Wing
  • Taranis x9d plus se 2019 with OpenTX 2.3.10
  • FrSky Archer RS using ACCESS

It worked for me with the following settings in arduplane:

  • TX6 instead of RX6
  • RC_OPTIONS,8 (not tried if this is necessary)
  • RSSI_TYPE,3 (not tried if this is necessary)

All the best and thanks again!