H743-WING V2 and No GPS


I’m having an issue with a Matek H743-Wing V2 not detecting any GPS module. I’ve tested with two boards both on 4.1.2 with a M9N-5883 (worked on my F405-Wing when I tested) and a known working M8Q-5883 that also works on the F405. I’ve tested on serial 3/4/7 and all have the same issue.

Any idea what options might I need to tweak or mess around with?

To which port did you connect the GPS modules and what is the parameter setting for them?

Default settings (38 for baud, no options, serial protocol 5) on serial 3, 4 and for fun I also tried on 7. I toyed around with GPS_DRV_OPTIONS = 4 and also 5 but no difference.

Hi @drank,

Are you aware of the different serial port naming of the H743 board?
Different to the Matek F405-Wing here the ArduPilot port numbers does not match with the port names on the board.
More details can be found here: MATEK H743 docs

Scroll all the way down to find the info you may interested in.


Wow that was the big dumb on my part. This was 100% the issue. Thank you!

1 Like

Don’t ask how I know this :wink: :wink: