Servers by jDrones

H743 Wing rover not saving changes after power down

I am having an issue where once I save parameters and write them to the FC , disconnecting the FC from power causes the settings to be wiped. This includes flight mode settings , UAVCAN settings and rover steering settings. I have had no need to modify anything else yet.
I am using ArduRover V4.1.0-dev

If I load plane, (which can be done from inside mission planner) any parameters I change are saved correctly after disconnecting power . (CANBUS GPS operates correctly)

I have read a few threads where others have said they are successfully running rover on the H743.
I am quite new to later model controllers so I could be missing something basic. Any thoughts appreciated on the matter.

Cheers.

It would be appreciated if you could send us the contents of your APM/STRG_BAK directory on the microSD card so we can analyze the corruption that happened.

1 Like

There are no files on the SD card. I checked with both rover and plane installed . I checked through MAVftp and by removing the micro sd and plugging it into my pc. Reformatted and tried again and got the same result. SD is formatted in fat32.

strg_bak rover

bak plane

Sorted the SD. New card is working.
Please see files attached STRG BAK.zip (1.1 KB)

Any updates at all? Any other testing you would like me to do that may help?

@tridge did you see this one? is about H743 parameter resets

1 Like

with master rover on a MatekH743 I see memory guard errors. That means we have a null ptr dereference.
I’ll see if I can find it.

also, params are not persistent …

I have to apologize. I lost track of the firmware versions my rovers are running. The rover with the H743 Wing is actually running Ardurover 4.1.0dev. I wrote that it was running 4.0 in the other thread.
I do not have problems with 4.1.0dev, though. I did not update for a while, so perhaps recent changes messed something up.

this PR fixes it:

1 Like

I will try this Tomorrow afternoon and update here.
Thanks for looking into this issue.

it is merged in master now

1 Like

Ok same result. I have noticed that after writing parameters ("parameters successfully saved "dialogue appears) that when going back to the initial setup page that the mandatory hardware tab is missing and replaced with loading. A message showing “Parameters are still loading. Many screens will not work until parameters are loaded.” This shows for approximately 90 seconds before mission planner returns back to normal. I’m not sure if that means anything or is completely normal.
.BAK attached below

write param wait

maytek H743-2.zip (2.4 KB)

Test with latest “ArduRover V4.1.0-dev (5a941ce0)” on Matek H743-MINI.
Parameter changes are not persistent saved. Has old value after reboot.
When arming shown in MP:

  • Internal Error 0x4000000
  • Prearm: Param storage failed

The APJ “latest” for MatekH743 is one day old. Maybe is was not build after the change?
Alle other tragets were build 8. April.

With the new latest “ArduRover V4.1.0-dev (fd88e53b)” it seems to work.
Parameters are stored permanent.
No errors when arming/disarming.

At the very first arming after flashing I got this.
But not any more after I rebootet the rover again.
grafik

1 Like

It is working well now for me also. I may have jumped the gun and downloaded the file too early.

Thanks again for looking into this. Onto the next problem😁

Servers by jDrones