Gyros Inconsistent after Boot


I have BlackCube, and on one of my drones, after some minutes started, the “Gyros Inconsistent” error show up. If I takeoff at the moment I have 3Dfix, no problem, but If I wait more the Gyros problem appear.

If I reboot the pix I can takeoff again, but the same, some minutes without takeoff and the Gyros Inconsistent show up again.

If I fly and land, the same, some seconds after landing the Gyros Inconsistent show up again.

I have calibrated de Accelerometers so many times, even with a electronic level, and the same.

I have been reading here to some people had the same issue, and I saw maybe could be because the temperature of the IMUS at calibration is too cold?

I will appreciate your help!


Yeah, this could be caused by the temperature. The gyros are automatically calibrated when you power on the FC - this is indicated by the red and blue LED flashing. As the IMU warms up, the gyros might develop differing biases.

You should be able to observe this by:

  • Turn on disarmed logging and set BRD_IMU_TARGTEMP to 60
  • Turn off the drone and let the FC cool down if it has been powered on for a while
  • Turn on the drone and wait ~20 minutes.
  • Download log and look at gyro readings vs. IMU temperature. Also look at the EKF gyro biases in NKF1.GX, GY, GZ.

If this happens and causes a gyros inconsistent error, you only need to recalibrate the gyros by rebooting the FC or issuing a gyrocal command (not sure if Mission Planner has a button for this, but Mavproxy can do it). You may find that setting a lower BRD_IMU_TARGTEMP can help prevent this if you are in a colder climate.

Gyros will be inconsistent any time there is change in the IMU temperature. Calibrate once things have stabilized. It depends on your climate, but I’d set your IMU target temp about 20 degrees above your average ambient tempeature. Calibrate your accelerometers when the temp has stabilized, and reboot once your temperatures have stabilized. Your problems SHOULD subside, but cold booting will never be great.

You can also disable the heater by setting the target temp to -1. That would also probably help your problems.

Thanks both for hour help!

Here are 31°C when the drone is flying.

I was checking the configurations from the them, and the BRD_IMU_TARGTEMP is 45, but as you can see in the log, it goes up to 55°. This is normal?

Something strange I saw too is the IMU 2 Temp is 0, thats its correct or normal?


Yes, the IMU heats up on its own without airflow (even without the heater). You should turn log_disarmed to 1 and monitor it for a while and then conduct some flight tests to see if airflow changes your normal or achievable temperature.

1 Like


The last picture its from a flight. The Cube is inside a canopy that prevent an external airflow, It just have a fan to take out the hot air.

What about the imu2 temp=0? thats its normal?

I have read another telemetry from another cube and the imu2 temp is too.


It depends on the board you are using; I think the orange cube only has 2 IMU’s, One on the heated isolated board and another elsewhere. Cube blacks have 2 IMU’s on the heated board. To be honest, I’m unsure.

1 Like

Yeah, it’s normal for IMU2 to have no temperature on Cubes. It is located right next to IMU 1, so you can assume that they are the same temperature.

1 Like

Thanks of both of you

Yesterday I did a default reset to try it, and until now, no more Gyro problem… may be some parameters were “touched”…