Servers by jDrones

GPS glitch + EKF failsafe at full throttle

I built a Octo-Quad copter with 18 inch props and set the rig up properly. I tuned the PIDs so far and I think it flies very good in Stabilize.
But when I do full punch out on the throttle I get a GPS glitch and EKF variance error. First I thought it is a GPS/Compass problem so I tried three different GPS units but the faults remain the same. When I changed the GPS, I always did a compass calibration and was calibrated successfull (I did one compass calibration in this mission so it is in the telemetry log).

The copter flies reasonably well in Auto and Pos Hold flight modes when it does moderate throttle. But I always have little toilet bowl effect. Missions work as well but I am sure if one day there is stronger wind and it has to fight against it, I will get the errors again and I am scared to lose or crash it.

Does anybody have an idea what could be the reason? Would you think it would help to swap the FC (I have a fresh Holybro Pixhawk 1 on the shelf)?

FC: original 3DR Pixhawk 1 with ArduCopter 4.0.5 and ChibiOS
GPS units tried: 2x Drotek M8N+Compass XL units, 1x cheap ebay M8N+compass
GPS is sitting on a pole 15 cm above the frame

tlog: https://www.dropbox.com/s/cse2tzm04l6z6rq/2021-02-16%2016-33-59.tlog?dl=0
fc logs attached (3 logs as it restarts a new log after disarming):
1: https://www.dropbox.com/s/1hvqcdp02m9fk2x/2021-02-16%2016-35-29.log?dl=0
2: https://www.dropbox.com/s/yhxuvgqz9er1jny/2021-02-16%2016-45-59.log?dl=0
3: https://www.dropbox.com/s/87g1w72btiwy3y4/2021-02-16%2016-58-00.log?dl=0

Any help would be appreciated!

It is pretty straightforward. Your compass is too close to motor wires. Large throttle generates large magnetic field and compass goes haywire.

I have a quad that used to do this. I solved the issue with a better GPS antenna, an extension to the frame to move it farther away from the wiring and a shielded GPS cable. I did all three mods in one go, so I can’t tell the impact from each.
I used a shielded USB3 cable and a GPS “stolen” from a DJI A2 with the CAN electronics removed.

Thanks for the info. So you think even 15 cm up is not far away enough? What about the GPS glitch? Same issue?

thanks for the hint! I will try a USB3 cable first before I disassemble my A2 GPS as I still need it! :slight_smile: But if that doesn’t help, I will try the GPS. How far is you GPS away from the frame?

One thing I forgot to mention:
My batteries are on top of the frame so the GPS is close to the batteries. Could that be a problem too?

Batteries on top IS the problem :slight_smile:
When your drone tilts, the batteries start obscuring the GPS antenna’s view of the horizon. And your best XY position comes from sattelites close to horizon. Hence the glitching.
If you want a good GPS antenna, look for the replacement part for Inspire 2.

I had my GPS at the edge of the center plate, on a 15 cm pole, as far as the original GPS cable allowed. With the USB cable giving me greater length, I put a 6cm aluminum extention from the plate’s edge. The prop arc forbade me going farther away, but the problem disappeared.

Great help, thanks! I ordered a USB 3 cable so I will give that a shot!
I use 18’’ carbon props. Could they interfere as well? Otherwise I will print an extension as well with maybe the pole sitting on it.

I would only agree a bit to that because I get the GPS glitches as well when I do full throttle upwards with no tilt or roll. But I guess it is the magnetic interference playing the main role there.

Thanks for the hint! Is there a difference between Inspire 1 and Inspire 2 GPS unit?

Inspire 1 has the same antenna as the A2. Inspire 2 has the same antenna as the A3. They’re both Tallysman units of same size, so they should perform nearly identical.
On the electronic side, the I2 replacement unit is a simple serial NEO-M8N. And it has no mag, so you’ll have to add one. Look for a RM3100 breakout board.
I haven’t checked the I1 GPS. I’ve only seen pictures of it.

I ordered a RM3100 and a Inspire 1 GPS.
@ThePara Do you happen to know the pinout for the Inspire 1 GPS? I am not sure which port is 5V. Did you use the original JST-GH connector or did you solder straight on the board?

I have been flying a 18inch prop machine for years and 15cm is definitely too close. Mine is on a mast of approx 30cm. With magnetic fields I think if you double the distance from them the field drops by a 1/4 so moving from 15cm to 30 will make a huge difference. Props won’t make any difference at all

I’ve only seen the I1 unit in pictures. You’ll have to use a multimeter to check the connector.
On the I2 GPS the first 4 pins on the left are 5V, GND, RX, TX.

1 Like

I tried the same as it seems to have the same pinouts but it does not get recognized by Durandal. Did you change any Serial_n settings except the protocol to 5?

I’ve got a mast which is now 13 cm off the centerplate and 15 cm above. Compass errors disappeared but GPS glitch is still a problem. I will try to use a longer mast. What did you use as such a long mast?

It would drop more than that as it follows the Inverse Square law. It would be a ~83% drop in field strength from 15mm to 30mm.

1 Like

Hahaha, you are so right and that’s what I was trying to say d’oh! Thank you for putting that one right. Should have written drops to a 1/4 not by…Englund was never me best topic like.

Nothing else. Try swapping TX and RX.

Well you were certainly correct in the assessment that moving it from 15mm to 30mm will make a huge difference so the ground was covered :grinning:

Thanks, it was the wrong wiring. Now it is working! I will print a case and test it this weekend! Thanks for your help!

Today I tried to test the higher GPS pole but it was gusty wind. The copter was flying not too bad.
After a while I changed mode to RTL so the copter ascended to 40 m flew to the home point and started to descend. After a while the motors disarmed in flight and the copter crashed. In the log I see that it enabled crash detection in flight. The EKF Errors in the log were the same as before (when I do full throttle I get GPS glitches, so I will swap my GPS to the Inspire 1 GPS to I that works better).

Can someone explain to me why it did that in flight? THR stick was at center and it was still descending. So I can not explain why it did that.
I need to replace to broken arms before I can fly again. Will take a week or two.
logfile: https://drive.google.com/open?id=1utkvpwTUnpGzYn1oR1sbikb5mVNnkN-_

Thanks for your help!

Servers by jDrones