Gimbal configuration is not possible

Since AC 4.3.0 I can’t select gimbal type so I can’t configure my servo gimbal. How can I solve this issue?


Use the Full Parameter List and set MNT1_TYPE?

This is the default course of action when a field is inactive in Mission Planner.

1 Like

What are the parameter names for stabilize tilt and stabilize roll? These two input fields are also disabled and there is no param like MNT1_ROLL_STAB and MNT1_TILT_STAB.

Having the same issue . I am able to set MNT1_TYPE but can’t find a STABILIZE parameter. In addition the MNT1_TYPE doesn’t change the GUI disabled field.

This is because in 4.3.0 two gimbals (mounts) can be configured so the TYPE field will be in error looking for MNT_… Not MNTx_…

As is sometimes the case Mission Planner has some catching up to do. Keep trying the Beta update and at some point it will work.

MP beta version and AC 4.3.1 beta version - there is no param for TIL/ROLL stabilize. That
means, that I can’t configure any servo gimbal with stabilize function from Cube. That’s not
good! When this issue will be resolved???

Have you seen the posts by @rmackay9 about the new improved gimbal support?
Have you understood the changes?

@amilcarlucas Can you please tell me, which posts do you mean? Have done a search but doesn‘t find answers to my issue.

Hi @Axel_Weckschmied,

For a self stabilising gimbal (aka brushless gimbal) that accepts PWM input could you try setting MNT1_TYPE = 7?

You could try QGroundControl and see if that works for you.

*** SOLVED ***

Hi Randy, MNT1_TYPE = 1 for Servo is ok, but I forgot to set MNT1_DFLT-MODE = 3. Now it works fine :slight_smile: Thanks!

1 Like