Gazebo 11 simulation in Docker is missing MavProxy

I am sorry for duplicating some questions but I am totally new and I just cannot find the right answers :slight_smile: So if anybody help, I would be most gratefull.

  1. I have created my own docker file where I want to run the simulation of quadrocopter within gazebo11. Everything seems to be installed and ok, but when I run the it starts and then it kills everything with message mavproxy exited. And I dont know why, I checked and mavproxy was installed, but it was not found initialy so I have updated ENV PATH with the location of mavproxy. It is found after this, but it does not work.
  2. If I run the --no-mavproxy it seems to work and I am even able to connect to vehicle on tcp 5760, but the vehicle will not work since some preflight failures. Can I use this aproach to start simulation without mavproxy? Or is the mavproxy needed to make it work, to connect all the sensors from the gazebo plugin and so on?
  3. I would expect that I need to run it with mavproxy and connect to the vehicle on udp port, something like 14550?
    I am on ubuntu 22.04.
    Thank you in advance. Lukas

Ok, the solution is to run the docker run -t.