Fw/reverse mixed

I recently test flew my X frame quad copter. I found forward and reverse were switched.
Anyone have an idea whats going wrong? Can I switch them using mission planner, or do I need to physically change the ESC plug in?


Forward/reverse? Do you mean pitch? If so invert the pitch channel (chan 2) on the transmitter.

What is the correct motor locations for an X frame? I think I may have a problem there.

This has it: http://ardupilot.org/copter/docs/connect-escs-and-motors.html

I havent used the Mission Planner method of testing motors, instead we:

  1. arm the copter
  2. closely observe 1 motor for spin direction
  3. it disarms itself if you do nothing, swap two ESC wires if needed
  4. proceed to check next motor and so on…

Be aware that the MP method of testing motors does activiate them in a different order to how they’re numbered in Arducopter and on the diagrams.

I used the motor number locations. It still has fw/rev mixed up. There is a problem where it wants to flip over when using roll, and yaw is working fine.
I never did a motor test with MP, I did calibrate the ESC’s.
Im at an impass with this.

Post a .bin log and I’ll see if I can figure anything out.
If you connect main output 1 to ESC and motor for Front Right and it spins counter-clockwise (and so on through the rest of them) then it should just work.

I tested each motor one by one and configured to Quad X. I have QX set as frame type. I also have the motors spinning in the correct direction, and the props are on in the right direction.
Its all messed up. I have it hanging from 6ft and when testing it, it wants to flip over with only thrust applied.
I might try running the MP wizard on it.

I reinstalled the firmware, hopefully that will help. I’ll post my results.

Just tested and it failed. I noticed this>
oh, how do I convert log to bin?

Noticed what? Just post the log file (.log, .bin) format doesn’t matter.

Sorry, Radio 3 is not working. I’ll get the file.

Log file here. Thank you!

it didn’t seem to attach to the post…

Don’t you just love it when they go right past the correct answer?

How do you fix the problem? How do I fix Radio 3?

I don’t see any problem with “Radio 3” as you call it. It’s at zero throttle. The descriptions you give make no sense. You claim a problem with forward/reverse (is this pitch, you didn’t answer?) and then say it “wants to flip over when using roll”. So what is it pitch or roll? Have you actually tried to fly this craft? Not “hanging from 6ft” whatever that means.

1 Like

Roll, Pitch, and Yaw are all mixed up.
On my first flight it instantly flipped over to the right on take off.
Second flight was the same as the first.
Third flight it flipped over to the left side. I switched two ESC plugs (Cant remember which) and then tried a fourth flight.
It hovered nicely, but Pitch was reversed, and I did not try Roll or Yaw. Then I configured the motors back to x-frame

So to troubleshoot, I mounted 3" props and hung the copter. I then tried giving inputs to Roll, Pitch, and Yaw. It behaved the same as on the field.

I’m wondering if I have a faulty Pixhawk

What is the correct answer?

Are the motors connected in the above order?
Is it X or + ?
How did you come to the conclusion, pitch is reversed ?

It’s the QUAD X config.
When it was flying during flight 4, I pushed forward on the stick and it went backwards. It also did that when hanging in my jig.

So reverse pitch on your radio as suggested. What don’t you understand about this?

1 Like