FRSky X8R Telemetry with Pixhawk

Hi. I have a quadcopter with the following setup and I’m trying to get telemetry to work with the smart port on the X8R.
Receiver: X8R
Transmitter: Taranis X9D plus
Flight controller: Pixhawk

I followed the guide and soldered together a custom cable with the SPC cable and TTL-RS232 converter. After all the setup, my taranis transmitter is only seeing 4 parameters:

RSSI - 100dB
A1 - 4.9V
A2 - 0.0V

From my understanding, these are the parameters that are passed by default from the receiver (not from the pixhawk). What am I doing wrong? I have tried using both SERIAL 4/5 and TELEM1 with SERIAL4_PROTOCOL and SERIAL1_PROTOCOL respectively set to 4 (not at the same time though).

Is there anything I may have missed, or is it possibly just a bad cable (how do I go about testing the cable)? Please help! Thank you!

Try arming the aircraft, then do “discover sensors” on the Taranis. That worked for me when I had a similar problem.

Thank you for the suggestion! It turns out it was a damaged trace on the PCB on the SPC cable (with the diode). The signal line was measuring open on a DMM. I had a spare one I replaced it with and I see a bunch of other readings now on the transmitter.

Hi you could also configure serial protocol 10 and use this script