Servers by jDrones

Frsky Telemetry on Matek F765

Hey all,

I’m a bit stuck here. I can’t get my F765/R9MM to send telemetry to my transmitter. SmartPort is connected to SERIAL1, protocol is Frsky SPort (4). I’ve tried it with Plane 4.0.5 and 4.1.0_dev. Tried using both the uninverted and inverted SmartPort connection, but since it’s an F7 this shouldn’t matter anyway. Tried manually setting the SERIAL1 options to inverted Tx, no luck.

We can exclude any wiring or hardware issues, since it works without issue with iNav. I’ve got a similar configuration (different FC though) on a quad where it works as well.

Any ideas?

Cheers, Oli

Pretty sure I cant help but if you did not check this out, seems like F765 is different from other Matek FC in terms of telemetry.

http://www.mateksys.com/?p=4488

Hey thanks for the tip. I’m currently using it with Smartport, but I’ll try an FPort configuration and report back.

I have success in installing Yaapu program on my transmitter Taranis 7Q https://youtu.be/AL-b1EnsAOE
The script was tested on the R9M FLEX FCC module and the Matek 765 WING flight controller and the Taranis 7Q FW 2.3.5 Open TX transmitter.
To connect to the Sports of resiver R9, I made an inverter (adapter) on the on the BC547 transistors, to obtain signal levels on Rx Tx 3.3 B applied the linear regulator LOW DROPOUT VOLTAGE REGULATORS LM2950 3.3 V
Installation options in The Matek 765 WING (UART 1 for Matek matches SERIAL2 ARDUPILOT) :
SERIAL2_PROTOCOL 10 FrSky SPort Passthrough (OpenTX)
SERIAL2_BAUD 57frskyinvert

HI, i have a R9 Mini working with smartport and Yaapu Telemetry without hardware inverter on a F765 wing. (Arduplane 4.0.5 Stable.)

Note that SERIAL6 on arduplane is the UART 4 on the Matek.

1 Like

Cause this is the top google result searching for “f765 r9mm fport”, this is what needs to be done to get this working:

  1. flash an fport firmware on the receiver. Did flash 190201 from here.

  2. From MissionPlanner set variables:

    • BRD_ALT_CONFIG to 1
    • RSSI_TYPE to 3
    • SERIAL7_OPTIONS to 15
    • SERIAL7_PROTOCOL to 23
    • NO NEED to touch RC_OPTIONS from the default value of 0
  3. Enjoy.

Working on Plane 4.0.6 (036ad45), R9M 2018 ACCST, OpenTX 2.3.10.

** If you haven’t installed MissonPlanner recently – in MP, press Ctrl-F, from the window that appears click “Param gen” (7th in the left column), wait ~1 minute, and restart MP. This will update MP so it can edit the bitfields. BTW, @Michael_Oborne, it’s not such a bad idea for MP to do that on every firmware update, I think.

This is great - any chance to have it ported to ArduCopter? I use f765 and h743 on all my big copters

Servers by jDrones