FrSky FPort support - testers wanted

you can use master firmware now (‘latest’ in as it has been merged
see instructions for MatekF765 above

I have a Kakute F7 AIO and a R9MM and Fport is working for both RC input and telemetry (yaapu). It’s on the bench not flying but all features seem to be working.


great! At least this means it can work. Still need to work out why it doesn’t work for @webmotions

R9mm has two fport pins: inverted and non inverted. What pin did you try?

This one (R9MM) and if it matters it’s FCC fport. I have an R9 I could try also but I think it will work. It’s the same level of firmware from Frsky.


I tried out an R-XSR with F.Port on latest master copter on a Matek F405-CTR and I can’t seem to get it to work at all. I have the “Uninverted S.Port” pad soldered to TX1, but I tried TX4 as well.

My settings are as follows:

  • SERIAL1_BAUD 115200

Whenever I go to the radio tab in QGroundControl I get this message:

just no channels available at all…

It works under Betaflight w/ full telemetry on TX4, no SoftSerial enabled and serialrx_halfduplex=on

**EDIT: I was dumb and didn’t realize the serialX settings don’t match up with the uarts on the board. It works now with no additional inverters required. :slight_smile: **

SERIAL0 = console = USB
SERIAL1 = Telemetry1 = USART3
SERIAL2 = Telemetry2 = UART4
1 Like

To have it working without hardware inverter on F4 chips you need use bottom pin.
It is like “hardware inverter included”

If is needed test on Pixhawk1 with R9 Slim and Taranis X9D, just provide me image and short explanation how to wire and set i can test on my system.

The R9 Slim doesn’t have an Inverted Sport (unless it’s a +) so you will need a hardware inverter.

No… on R9 Slim+ you can use one of the UART ports on the receiver for F-Port. Marked RX ot TX i am not sure have to disassemble my drone to check, i use this connection on with betaflight.

Yes, that’s what I meant. Inverted available on Slim + not Slim which is what you said you had.

Successful bench test on CubeOrange with an R-XSR using F.Port and ACCESS firmware on an X10S Express. Yaapu script works as well!

@tridge I tested the following without success on CubeOrange in Telem2

R9M 2018 and R9 receiver: FCC ACCST v190117 and v190201
R9M 2019 and R9 receiver: FCC ACCST v190117 and v190201
R9M 2019 and R9 receiver: FCC ACCESS v1.1.1 and v1.1.2

I can mail you some 2018 R9 equipment if you’d like. PM or email me

what flight controller did you use, and what serial ports?

if these can be updated to support FPort then yes please!

I’ve tested with a RXSR receiver with FPort beta firmware on a CUAVv5Nano. Works nicely.

My mistake i have Pixhawk1 with R9 Slim+ and Taranis X9D.
Where i can find the image to test?

I also have those receivers:
R9 Slim+
R9 I hope i can use more than 8chanals with EU version and F-Port telemetry

And those FC:
Omnibus F4

just load the ‘latest’ firmware and follow instructions in the first post above

Tested with MicroPix and R9 Slim+
Connection: 1 wire between R9Slim+ RX pin and Telem1 TX Pin on MicroPix

  1. Proper channel readings 1to8 from 8 to 16 are not visible on the APM/QGC not tested
    2.RSSI readings are divided by 2. i have RSSI reading 100 GSC show 50.
  2. No telemetry returned from the FC to taranis.

enable MAVLink2 and it can display 16 channels on the GCS. Set SERIALn_PROTOCOL=2 for the link you are using to GCS

Thanks, I hadn’t noticed. I’ll push a change to make the scales match.

I don’t have a MicroPix but I think it is likely a F4 board, so it will need an external inverter setup.

Tomorrow will continue testing i will try same test with craft and theory MAX3232 if the logic level consist. But I have previous issue with S-Port Pass after i jump from 3.8 to 4.0 Plane i cannot manage to start this protocol. I don’t know how is implemented F-Port and which type of telemetry use S-Port/S-Port Pass. If is S-Port Pass based may be this is the reason why i don’t have telemetry.

I am hardware engineer… but for this uC i am only user i never read their datasheets.
Will be great if F-Port can be implemented on SBUS IN port, this will free one UART.

The MicroPix is ARM Cortex® M4 based… some kind of Chines micro version of Pixhawk1