Servers by jDrones

FrSky FPort support - testers wanted

I notice that the F4 boards such as the Matek F405-Wing need an inverter cable for the F.Port protocol.
I was hoping switching to F.Port would remove this necessity since the Sbus pin handles the inverted signal. Oh well. . . .

we do soft-serial for input but not yet for output. I would like to add support for soft-serial output but haven’t had time to work on that yet, sorry.

Hmm, can’t get it to work with FPort option flashed R9mm and Cube orange. Arducopter FW downloaded from https://firmware.ardupilot.org/Copter/2020-01/2020-01-04-01:01/CubeOrange/
RC in works, but nothing comes through passthrough back to Horus. All parameters set as specified. How to fix this?

check other serial port, half duplex cannot work on all serial

he f4? f4 not supportted ,later

No, Cube Orange has H7. Is there any documentation about which port supports which feature?

All UARTs on H7 support half-duplex. Which serial port are you using? All should work except for SERIAL5, as SERIAL5 is connected to the Ping ADSB receiver on CubeOrange.
Here are the settings you need if you use the telem2 port:

  • SERIAL2_PROTCOL=23
  • SERIAL2_OPTIONS=7
  • RC_OPTIONS=8
  • RSSI_TYPE=3

you would need to connect the receiver to the TX pin on telem2. The TX pin is the one next to the red 5v pin.
Also note that you will need to disable use of FRsky telem on any other serial ports.
I have tested this on CubeOrange and it works fine with current master build.

Hello tridge,
what is the correct boud rate? I’ve tried 57600 and 115200, both are working for rc input.
Recompiled ArduCopter 4 from Master. I tested Serial1 and Serial2. With RC_OPTION = 0 or 8 and SERIALX_OPTIONS = 7 or 4 I get RC input. But in no case telemetry. Probably it is because of R9MM. Unfortunately I can’t test the new Access Firmware because my R9M is from 2018…

I don’t have any test results, but I am very excited about this! ArduPilot is now a huge step closer to taking an RTF betaflight quadcopter, and being able to just re-flash the flight controller to fly ArduPilot.

Is there any advantage to using FPort over Sbus over RCIN and S.Port pass-through on an orange cube? On other boards there’s a clear advantage to freeing up a UART but on the cube you don’t get that.

Main advantage is you get RSSI, plus the telemetry bandwidth is a lot higher with FPort (higher baudrate), and you could do two receivers, one on RCIN and the 2nd with telem on a serial port.

1 Like

It is 115200, but it sets it automatically, so it doesn’t matter what you set.

ok, if you do want to investigate further than you would need to get a logic analyser trace so we can see what is happening on the uart.

I don’t have a logic analyser. I could try listening with Wireshark?
But I have other receiver types to rule out that the problem is the R9MM.

which other receiver types have you tried, and what was the result?

tried an R9 today on ser1-3 with specified settings and no success. RC in works, telemetry not. I have no idea…

tried an X4R with FPort firmware and it works out of the box with Cube Orange. So the issue is R9 and R9MM?

Wow, this is cool. Now we can create another one alt config for PixRacer to have SPI port instead of WiFi

quite possibly. Does someone with a R9 setup have a logic analyser to get a trace of what is happening?

that should be possible, yes.

no, it needs a logic analyser, preferably a Saleae.
If nobody else puts their hands up to say they have one and a R9 then I’ll but a R9 module for my taranis and a receiver

I have Matek F768 with R9 (telemetry setup and working on SPort)
Will try to have a time to check if the telemetry working on FPort.
As I briefly understood I don’t need to resolder anything just reflash R9 and use @tridge firmware?

Servers by jDrones