FrSky FPort support - testers wanted

Matek F765 R9m Slim plus OTA receiver Fport settings/setup.

For matekf65 with R9m Slim plus OTA Telemetry, below settings works.
Using Arduplane 4.1 Beta

  • RC_OPTIONS=0 (8 didnt work as developer advised)
    And make sure:
  1. Change the receiver settings from Sport to Fport.
    2)Sport/Fport cable connect to RX6 ( Same as you do connect for SBUS, as Serial7_options settings swap the pins)

How to change the receiver settings in open TX
Go to Model>>Scroll down to your receiver 1 tab>>click to open and select options>>on top change sport to Fport. ( make sure you have the latest firmware)

Just tested on an orange cube with 4.10 dev beta 3 with an archer M+
On X12S with isrm module installed and X7Q access radio works great

    Note: rx/tx swapping means FPort has to be wired to the RX pin!


Matek F405 Wing - FPORT
No external converter required with R9 Slim plus receiver or with any Frsky receiver, can support inverted Sport/Fport (mostly does).
R9 Slim plus:
RX1 port on the receiver need to be connected/use instead of Sport/Fport. As RX1 is inverted S.port port not the Sport/Fport. Sport/F.port is for F7 flight controller.
Make sure receiver has latest firmware and you have enable the Fport from open tx option.

  1. Connect receiver RX1 to TX2 (UART 2)on flight controller.
  2. Config below settings for serial7 ( serial 7 maps to Uart2 as BRD_ALT_config=1)
    SERIAL7_OPTIONS = 4 (Half Duplex) RSSI_TYPE =3
    Serial7_BUD = 115 ( mine is works perfectly with 115, try 57)

Enjoy the yappu telemetry on your transmitter. Dont forget to delete all sensors and discover again under openTX system settings.

If connnect r9slim+ RX1 to TX on Uart6 of F765wing, how to setup?

By reading the Wiki. Page down to where is says Matek F765-Wing


Hi Dave,
I did read it. and tried many other setting. it is not same setting with the link says.

  1. Connect receiver RX1 to TX6 (UART 6)on flight controller.
    RSSI_TYPE` =3
    Serial7_BUD = 57

or Connect receiver RX1 to RX6 (UART 6)on flight controller.
Serial7_BUD = 57

Matek F765wing with Frsky R9slim+(Fport flashed)


Any specific reason to connect to tx6 ? As better connect to rx6 as negative, positive and live wire all 3 aligned.

If you still want to use tx6 just uncheck the swap check box under serial 7 option.(I didn’t try it but it should word as swap check box swap the tx and rx pin, which translates rx become tx and tx become rx.

Thank you for your reply.

The reason I wanna use tx 6 first I wanna give a try, just for the curiosity. Second I use inav which TX on fport. So I don’t need to change the wire when I switching the firmware.

Ok. Just make sure r9slim has fport protocol selected. Protocol can only be changed from opentx transmitter menu selection.

yes my r9slim+ is old version of Fport. It cannot be selected from the radio. But they are both fport flashed.

I read this entire thread twice and still spent a very long time this morning trying to successfully use FPort on a Cube Orange with an R-SXR receiver, Horus X12S (OpenTx) transmitter, and the Yaapu telemetry scripts. The Cube is presently running Rover 4.1.0-beta7.

The biggest issue is that FrSky’s ACCST 2.1.0 firmware appears to be incompatible with ArduPilot’s FPort implementation. I finally found a copy of the 1.9-series iXJT firmware for the X12S, flashed that, reverted the R-XSR to the 1.9-series as well, and everything worked immediately without any hiccups.

The receiver is wired via its DF13 connector (not the solder pads) with a 10k pulldown resistor. The following recommended settings worked on both SERIAL2 and SERIAL3:

I’m very happy to have FPort working, but it’s slightly frustrating to have to revert my other receivers to ACCST 1.9x if I want to keep this rover working as-is.

Reference my previous post just above, I was very happy to get FPort working with the firmware reversion, but that has created another problem for me.

With the older firmware on my transmitter, I’m either forced to downgrade my X8R receivers to a version that does not support pass-through telemetry, or rewrite the firmware on my transmitter every time I switch from the R-XSR model to an X8R one (of which I have two).

Have I done something terribly wrong by downgrading to 1.9x in order to get FPort working, or is ACCST 2.1 FPort support forthcoming?

See immediately below. The issue is not an ArduPilot one, but rather a FrSky one.

Hi, there’s no such thing as a specific accts 2.1 fport, what you experience appears to be a frsky firmware issue and you’re not alone

1 Like

Ah! I did read a bit about that bug but did not fully digest its impact (it seemed Betaflight specific). That makes perfect sense, and the developers here can disregard my somewhat ignorant request for support. Thank you much for the explanation!

A brief test with the ACCST 2.1.2-beta firmware linked in that bug report was completely successful. A word of caution to those considering this “fix” - there is a follow on post that appears to blame a copter crash on this beta receiver firmware, so it probably shouldn’t be used in any critical application. In my case, I’m using it on a small Rover that I purpose built to test things like this, so the risk is close to nil.

In the long run, perhaps it might be best to simply upgrade my transmitter with an ISRM module and transition to ACCESS.

1 Like

Hi, access works fine on that receiver on an X10 with ISRM upgraded module :slight_smile:

1 Like

Yes time to update the module.

1 Like

HI Anton, Is there a Fport firmware for an X4RSB with ACCST 2.1?

I imagine you will be in ACCST 1.9 right?

Thanks in advanced!

I think so. Check FRSky site, it should be there.

Hi Anton, on the official frsky website it is not available for ACSST 2.1. I imagine you are using version 1.9 on your X4R, right?

El El mar, 14 sept 2021 a las 7:19, Anton Khrapov via ArduPilot Discourse escribió:
Under ACCST D16 FIRMWARE, downloaded that zip file. It will have both FPort and SPort firmware version 2.1.0