Follow-me arducopter

Hello everyone I have a problem with the flight mode follow me with tower, after the last update 3.6 no longer works.

Please report that issue at the Tower github site

Thanks

hi, why is it a tower issue if same tower works with 3.5.5 copter? i had same problem - follow me is dead, it switches vehicle into a guided mode, but there is no movement. land and some other commands still work fine from tower.

While ArduPilot (Plane/Copter) has been evolving, Tower has had very little TLC, so it is expected that some features will stop working.

has ‘follow me’ guided mode changed in any way how it communicates in/out? it was same since, gosh, 2.8 release, may be?

Please check how it was done at the Tower source

i am only trying to be logical about it, as if i was a tower developer, a most rational response to a claim that something out there stopped understanding a protocol that worked before would be to send that request back to the author of the protocol to adjust its ‘understanding’ back, where it was before.

as i am neither, i can only state that is it highly annoying fact that 3.6 rc builds suddenly stopped communicating properly with the tower app and with tower beta app as well.

Being logical, is that Tower last commit is from Nov17 (dev branch), and requires some heavy refactoring, and unfortunately the lead dev has no spare time to do it.

i understand your point of view, but, what i think is also logical is the fact that it was a lot of time since Nov 17, and 3.5.5 worked fine, and now 3.6 rc does not - and tower is unlikely to be changed as author does not care - so - is there anything that can be done in 3.6 to make it talk to the tower like 3.5.5 did? and 3.4 did? and 3.3, etc?

My understanding is that Tower was using guided-position-control to move
the vehicle around as a “follow” mode.

Yes, we have something better now, but Tower will not currently support
it.

However, the old functionality should definitely not have broken.
Legitimate reasons for it breaking may include additional safety
precautions which Tower isn’t aware of - I can’t think of anything along
those lines, however.

If you can get us a short telemetry log showing the problem that may help
diagnose. Note that we have regression tests for this functionality (on
the master branch) - so it is working in some way, shape or form on
master.

I should have a log sample, will send link later today.

here is a log with a sample.
https://drive.google.com/file/d/1WchXDz79HpIhanvlv0Jd9kUj2zP1f2vO/view?usp=sharing

‘land’ and ‘brake’ commands were accepted. on the ‘follow me’ with attempts to use 2 different modes - ‘leash’ and ‘above’ - there was no reaction. it was sitting in the same spot in pos hold mode.

[45.png]
Paul_Atkin1 Paul Atkin
August 1

here is a log with a sample.
https://drive.google.com/file/d/1WchXDz79HpIhanvlv0Jd9kUj2zP1f2vO/view?usp=sharing

Sadly, that’s a dataflash log. Usually they’re superior to tlogs for
analysis - but not in this case, as I need to see the commands going from
the GCS to the autopilot - and that’s in the tlog.

¡land¢ and ¡brake¢ commands were accepted. on the ¡follow me¢ with attempts to use 2 different modes - ¡leash¢ and ¡above¢ - there was no reaction. it was
sitting in the same spot in pos hold mode.

Yep, I can see that much in the log you supplied.

i will try to get laptop out later this week to try to catch tlog, or may be somebody else would be able to provide a sample… thx anyway!

Also Tower Beta saves tlog, in my phone under “Android\data\org.droidplanner.android.beta\files\tlogs”

if you could provide a log from current 3.6 rc7 it would be great - i cannot get to it neither today no most likely tomorrow…

Yes, we should try and get to the bottom of this. I can’t immediately think of a reason why it would have stopped working. There was that issue with Tower specifying absolute altitudes instead of relative…

The Solex app is a decent alternative to Tower because it is maintained but it’s not open source nor free.

QGC also runs on tablets I hear although I don’t know if it has “follow” as a feature.

Hi, I tested Copter 3.6 (master 81b1270) on omnibusf4pro using Tower Beta on my Android phone as GCS and I tried to do follow me with same results as described by @Paul_Atkin1
I attach the tlog file, near 42% there are some tentative to switch in follow me mode.

In the tlog there is another strange behavior: till near 35% there is a big value of compass variance error, then this value goes low and remain so till the end but without any intervention by me. In the phase with low compass variance I obtain a really good Loiter. I understand that this thing is OT, I have to do some other test and maybe report the results in another thread.

https://github.com/anbello/Hello-World/blob/master/log_tcp_2018_08_05_19_16_34_313.zip

@peterbarker in my previous post I attached a tlog from Tower Beta where I try to switch to follow me mode without success, can you analyse that tlog to see if there are info to understand the issue in this thread? Or maybe you can explain me what I have to search in the tlog.

Thanks
Andrea

One theory that we’ve had about Tower not working is we’ve changed the VFR_HUD mavlink message to (correctly) report the altitude as height above sea-level. We suspect that Tower was built around the incorrect value and this is the cause of the troubles. We need to verify this but it’s the leading theory. Once it’s verified then we can try and figure out how to fix it… fixing Tower would be best although it’s unclear if we can find any developers to take this on.