Flyaway Problem


I’m quite new to the forum but have experiences in Arduplane already for several years.

Recently, I have flew my quadplane based on Arduplane 3.7.1 with many auto flights with no problem. But last time, I tried to used my own GCS with full auto flight. During the mission, there was no problem with it. However, after I switched back to mission planner for another flight, it seemed that the vehicle could not reach the 2nd waypoint after transition from VTOL mode. Then, it tried to maintain the heading and fly away and I had to called it back with RTL. Fortunately, RTL worked normally. This behavior occurred 2 consecutive flights and I must reset the parameter so that the problem disappear. I tried to analyze the log but have no idea what was going on. There were some vibration issues but not sure if it could cause gyro to drift. Another information is that this board lifetime is more than one year and I crashed and had hard landing several time before.

Does everyone has the idea what can cause this fly away problem ?
Here is a set of log files for flights with fly away behavior


thanks, I’ve had an initial look, and I haven’t yet spotted the problem. It is probably related to using NAV_LOITER_TO_ALT as the 2nd waypoint, but that should work fine. It should have circled around the waypoint until it gained the required height.
I’ll come back to this log again when I have some more time for a deeper analysis.

Thanks Tridge. It normally circles around NAV_LOITER_TO_ALT waypoint to desired altitude without problem. I repeated the same mission for many times before. There was no issue until the latest flights which I mentioned above.