Flight Mode won't change in Mission Planner

I set 6 different flight modes and Ch 7 is responsible for changing it. When I change the PWM signal, I see flight modes being highlighted with green, but neither in Config/Tuning nor in Flight Data screen it doesn’t change.

I even changed in config.h, but it still doesn’t work. Please help.

Thanks in advance

ch8 is the default mode channel.

yeah, but it doesn’t work even with CH8.

You have to calibrate the channel first.

Anyone found solution? I have exact same problem. Always on RTL, calibration not helping.

Could your FailSafe settings be causing it to remain in RTL?