Flight mode failed

I m working on lawn rover using version 3.5 in encoder Mode.i have done all setting parameter for the encoder.when i try to change mode it shows “flight mode change failed”…and one more when i m using version 3.2.1 then its work well.its not working 3.5.03_5_0_encoder.param (13.3 KB)

Txs for the param file. It may be that RELAY_PIN and RELAY_PIN2 haven’t been set to -1.

If you have a dataflash log file (aka .bin file) that might help determine the cause.

hi thanks.

  1. i hv tried on version 3.4.0, 3.4.2 but not succeed and system shows warning bad AHRS when i try to " set home here , set EKF origin here " but vehicle not showing.3_4_2_encoder.param (11.8 KB)
  2. about log , dataflash is generated but when i try see any log its show only empty but file file is generated.
  3. one more thing is i observed , when set mode Guided or auto 1stly and then armed it works on version 3.5.0.
    please help…bcz all these works on version 3.2.1 but not working on 3.4.0,3.4.2,3.5.0 .we hv tested rover using rtk gps mode it works well , we want it works on non-gps mode.

Hi @vinoba_jadhav,

I really need to see a dataflash log file. Maybe try formatting the SD card or replacing it?

hey thanks @ rmackay9
hi actually non gps mode not working on chibios 3.4.0, 3.4.2, 3.5.0 .its properly working on nuttx 3.2.1,3.4.0,3.4.2 .but still we are stuck in logs only imu logs are not generated . after solving this we will send u
please suggest can we go proceed with nuttx.

@vinoba_jadhav, it shouldn’t really depend upon whether NuttX or ChibiOS is used just like it shouldn’t matter which flight controller hardware is used. NuttX has already been replaced and there’s no going back… ChibiOS performs far better in any case…

here is dataflash file for chibios rover 3.5.0
27 1-1-1980 5-30-00 AM.bin.log (716.6 KB)
and parameter file 3_5_0_encoder.param (13.4 KB)


Thanks for the log.

The parameter setup looks OK and it does appear the the home and origin have been set. I don’t see any change in the WENC values in the log though. If you spin the wheels, do you see the RPM messages change? If you’re using the mission planner the RPM message can be seen in the Flight Data screen’s Status tab, look for rpm1 and rpm2.

It may be that you’ve hit this bug so I may need to actually test the wheel encoder feature on my vehicle to investigate and see if it has been broken.

thanks for help rmackay9.
currently we are using nuttx 3.2.1 and we got good result in both rtk gps and encoder.but we hv one issue with pid tunning ,we are generating matlab module for pid tunning and we want therotical pid tunning value can u help us about how pid throtal and pid streering works.also some structure during auto tunning.


The best advice for tuning is on our speed tuning and steering rate tuning pages. So if you could give that a try and then come back if you run into troubles that will probably be best. This advice only applies to more recent versions of Rover (3.4 and higher) and I’m afraid I can’t provide tuning advice for 3.2.1 because things have changed quite a bit.

Re the wheel encoders on 3.5, are you seeing the RPM messages displayed in the MP as shown in the screen shot above?

yes i can see rpm messages but ekf variance and flight mode change failed .messages occured ?
this 3.5.0 work for gps but non gps not work ? today we will send log and also parm file once again after tesing.

@ rmackay9
in latest version, there is gcs mask selection we hv seen two more option left wheel and right wheel

is this for pid tunning for skid steering,when i select this , PID_TUNING msg not received

@vinoba_jadhav, you can ignore those extra options I think. Those are for use with wheel encoders and the wheel-rate-controller (that relies on wheel encoders). Using these wheel-rate-controllers it is possible to add an extra PID controller to ensure the wheel spins at the desired rate. I’m afraid this feature isn’t well documented yet but you will see the WRC_ parameters in Rover’s full parameter list.