Flight mode change failed switching to autotune

Load the ChibiOs beta 3.6.0 rc1 to my Pixracer and when I switch to Autotune, get the message "Flight mode change failed ", it only happens with Autotune, all other modes work correctly.

Try on the air :slight_smile: It won’t work when copter is landed


I’ve never had much luck with autotune set as a flight mode. I usually have to set it to one of the two position switches on my Taranis. My flight modes switch is a six position rotary on the 9 Plus. I may try putting it next to PosHold now that AT does that (poshold autotune) and see what happens.

Thanks Andrea, last Sunday I went to fly my drone, I tried smart RTL, Loiter, everything worked very well, tray to switch to Autotune and it did not work.

Tanks Mark
I setup the Autotune on channel 8 of the transmitter, I have configured channel 5 with 6 flight modes and channel 7 with Smart RTL.

I have same problem but only when i change the flight mode from other (poshold, loiter, althold) to stabilize (manual). What can i do???

I have the same problem with Pixfalcon. all modes work except AutoTune. just get flight mode change failed message. Has anyone worked this out yet?

I think it will fail if the copter is not in a stable hover.

I seem to recall you need to be in Alt Hold or Pos Hold prior to switching to AutoTune. I also seem to remember getting this error when trying to switch into AutoTune from Stable. I’m an old man so things are a bit rusty upstairs. :slight_smile:


what mode are you in when you switch to auto tune? You have to be in Alt Hold. or Loiter as far as I know, I usually tune it in loiter because the stock copter tune is stable enough to do so and the alt. hold tune usually wanders all over the place.

you also have to make sure that your throttle stick is exacty at 50% when you switch over or else it won’t take the command. So if your copter wont hover at 50% throttle, you need to get that fixed first. Even being a smidge high or low off of exact center stick, it won’t start the auto tune.

Thanks Nik. This answers exactly the same issue I had and is another example what makes the Ardupilot community so great!