Servers by jDrones

First Run of a Nice Implementation of Autonomous Zero-Turn Mower

ardurover
mower
(Kenny Trussell) #1

A couple of months ago, Dave (@metalsman) contacted me. He and his son have been working on a zero-turn mower similar to mine. We compared a lot of notes and learned from each other via Skype and Facebook Messenger. At that time Dave was not to the point of running his mower in automatic. He has made huge progress and now has an operational automated mower. Here is his first run!

Some of his design features:

  • The actuators are assembled on a frame that is easily removable from the mower to allow manual operation and to allow work on the actuator subsystem on a bench.
  • He is using a Raspberry Pi running Solex Base (hope I have that right) to inject the RTK correction info into the MAVLink stream. The Raspberry Pi is also acting as a WiFi access point allowing multiple computers, tablets, etc. to connect via UDP.
  • Hefty (though a little expensive) Torxis servos.

In addition to a nice design and implementation, luck was on his side, too. Without ANY change to the tuning parameters, look how well his mower is tracking for its very first run. Look how snappy and perfect his pivot turns are. Dave is on his way to a great machine!

Dave, we look forward to more videos and other information!

Congratulations, Dave!

5 Likes
(Metalsman) #2

Kenny thanks for all your help and kind words. Credit to you, this group and to the amazing developers responsible for this great hardware and software.

I disassembled one of my treasured 3dr Iris Drones that had everything except the HERE RTK and the SolexBase - servos were sourced from eBay!

In the very near future I want to implement LIDAR - specifically forward facing obstacle avoidance that would simply stop the rover if it was running in Auto mode. I am currently using 3.4 but plan on upgrading to 3.5 and have not been able to surmise if 3.4 or 3.5 has the ability to stop an Auto mission if obstacle avoidance is triggered. Also I am not sure what would be a good choice for the hardware, since weight is not an issue but I would like it to work well with the pixhawk.

1 Like
(Shawn) #3

Just FYI

Ardupilot Unconference Object Avoidence with Randy Mackay

2 Likes
(Christopher Milner) #4

Very nice! Congratulations!

(Bitdog) #5

Awesome. @Robo_Roby has gotten his Zero Turn going and just posted this recently https://youtu.be/nCaJzeuDVOQ. We need a sub group for mowing folks :-).

(Robo Roby) #6

@Vincent_Miceli a sub would be nice – I’m shooting to have a big blog post detailing that build out within a week or so.

(Kenny Trussell) #7

Awesome video. Congratulations!

(Bitdog) #8

I would love to see pictures or videos of the actuator setup. I don’t have a zero turn yet but my 22" deck on my little guy is not “cutting it”. I wonder if all you guys did similar things when connecting your zero turns. Also attaching parameter files might be helpful. I have finally tuned my parameters and I am getting really good turns and straight-ish lines but with out the extra inches I am still missing chunks of grass here and there. I ran a 45 minute mission yesterday. What’s the record for mission length for ArduRover?

Congrats again @metalsman!

(Kenny Trussell) #9

I have run at least a 6, probably 8 hour mission, multiple times.

(Bitdog) #10

That is awesome to hear. I was worried about potentially undiscovered memory leaks in the flight controller code that might only be found during long missions. I would think they would have shown up during a 6 hour mission if there were any. Thank you.

(Kenny Trussell) #11

Well, when I wrote that reply, I didn’t have much time and also since this has been several months ago that I was running long missions, I can’t remember the exact symptoms, so I was hesitant to mention it, BUT since you did…

I did have issues that I thought were likely related to memory leaks. They were related to MAV telemetry communications. To the best of my memory what would happen is that if I disconnected Mission Planner for any reason, then I could not get it to reconnect properly. I believe that it would seem to connect, but no data would flow, e.g. the initial reading of parameters would not work and other indications would not show in MP. The vehicle was still executing the mission just fine and the remote control worked fine, so I was still in control, just blind as far as the mission progress was concerned. Cycling power on the Pixhawk would correct the problem. I had this happen 3 or so times, so it is fairly repeatable but requires a LONG mission. I am confident that I never saw it in a 2 or 3 hour mission, only the really long ones.

I would hate for someone to spend much time looking for this problem based on my report because I just don’t remember the details. At the time, I had so much else I was working on, I delayed really understanding the symptoms and reporting it. At some point, I will be running long missions again and I will do a better job of looking for issues and reporting.

Oh, another reason I didn’t report it is that the logs for a mission like that are so huge, I don’t think they could be analyzed. Is that true?

(Bitdog) #12

I did have the same problem not too long ago after a 1 hr mission. Really didn’t think much of it since I was done for the day. I’ll keep an eye out for it again.