Servers by jDrones

First Flight rising continuously and crashed

Hello everyone,

I am new here. My friend and I make our first quadcopter which is 550mm and includes pixhawk 2.4.8. We tried the first flight at the weekend. I started in loiter mode. Drone lifted about 50 cm and hang in the air for 5-6 seconds. Then, suddenly it started to rise. Rc transmitter can not control the quadcopter. It rose fast and turn yaw axis slowly. I swicthed the flight mode as stabilizer and took control again. But it rose about 30 meters. Then, I did panic and couldn’t control it, it crashed.

We wonder that what the reason of that is. I think that it can be because of transmitter connection but when I changed the mode, it continued. In addition, quadcopter can not switch failsafe because of a problem before the flight. So failsafe is disabled.

I upload the log file, can you help us to understand the reason?

Flight video: https://youtu.be/Al1ImMF-OJQ

Typically the problem is vibrations. Do a search in this forum and ypou will find a lot of posts about it.

Thank you for your answer. Yes, I saw the vibration posts now. Is the reason definitely vibration?

I did not look at the log file, sorry.
But now you can help yourself, just read some posts and upload the log file to plot.ardupilot.org to analyze them yourself.

1 Like

First update to current Stable Arducopter you are using 3.6.8. Then fix your vibration levels, they are high. Then follow these basic tuning guidlines.
https://ardupilot.org/copter/docs/tuning-process-instructions.html

1 Like

Hi,
it almost appears that basic calibration hasn’t been done.
…and yes, also issues with vibrations. Have props been balanced ?

Hi, we are new and we calibrate esc, transmitter, compass and, accelerometer. Then, what should we make? We don’t know prop balance but I realised that we made a great mistake that we didn’t put pixhawk to vibration dumpers. It was directly on quadcopter.

Also, how can we see this log information, and how can check before the flight?

The Auto Analysis Tool in Mission Planner is not up to date and is of little value. For example some of those fail parameters don’t even exist any longer or the parameters names have changed.

Props must be balanced and that Flight Controller must be soft mounted.

I posted this many times before, but here it is again: The right order is:

  1. first do a dynamic notch filter tuning
  2. then follow the tuning instructions
  3. then do the arducopter PID control parameters autotune

Please explain it to everybody. Lots of people jump right in to autotune and get strange results. We need to spread the word!! No shortcuts, do the list posted above, always!

@Ugur_Caglar_Caliskan please do the suff I posted above, do not skip a step. The list above is on the documentation, and multiple times on this forum, but people keep on skipping steps :frowning:

3 Likes

Do I need balance for new props, too?

Yes of course, all props need to be balanced.

As Dave said, ALWAYS balance your props. Even the great brand props sometimes (it seems most of the time) are not properly balanced. Just a few days ago I found out that my trusted, new, high price props were not balanced well at all (one of the four was ok). What a difference now!
Even a cheap chinese balancer can make a difference, but if you can spend a little more, get a Dubro balancer. It really pays off!

2 Likes

Hi amilcarlucas,
I think that following the tuning instructions first is the right way to go - get all the primary parameters set to suit motors, ESCs and props, maybe do some manual tuning (as per Leonard’s tuning guide) then do the Harmonic Notch filter.
I agree Autotune should be last (or at least redone after HNOTCH).

In a lot of cases it’d probably be difficult or impossible to do the HNOTCH work before getting a stable flyable aircraft via the manual tuning process. I know we’ve had multirotors go both ways: 1 that we put together and it always just worked, a couple that require careful tuning and considerable thinking…

1 Like

Indeed. With a small quad you likely can’t even fly it to acquire the Notch Filter data with the default Gyro filter setting. In many cases it’s a wobbling mess.

1 Like

Vibrations are definitely a problem here:


X and Y axis vibrations are most likely just prop balance (until it comes to descending)
Z vibrations are a bit too high to start with and that can cause the uncontrolled rise.
The high vibrations during descent can be address later, after you get it flying OK.

Start by setting these parameters:
ATC_THR_MIX_MAN,0.1
MOT_THST_HOVER,0.2

Use the Tuning guide https://ardupilot.org/copter/docs/tuning-process-instructions.html and the helper spreadsheet:
https://www.dropbox.com/s/8u9v3ddph6u9u3t/Initial%20parameters.xls?dl=0

Actually if you use MissionPlanner, just press ALT A and step through the dialogs to set all those params automatically.

Treat all the parameters in there as mandatory, especially the MOT and BAT params.
Ensure your voltage and current monitoring are accurate.

When you’re ready do another gentle test flight, try to get up a couple of meters high away from ground effect. Post that .bin log.

1 Like

Thank you for your all answers. They are quite helpful. I am repairing my quadcopter now. Then, I will review your post again and make sure everything is correct.

This is strange: vibrations before sudden ascent are in the limit of the recommended values 15/15/30, suddenly copter ascends to 62.5m, and when descending begins there appear the high vibrations.

Examining MSG messages:


version is V3.6.8/NuttX, so should be upgraded. Message “Vibration compensation on” message would appear with V4.

Examining some more parameters and events:


*when sudden ascent begins, throttle is brought to 0 (normal reaction), but ascent continues up to 62.5m. CTUN.ThO is also 0, but ascent continues (strange: pilot cannot stop ascent);
*“armed” and “auto_armed” events are seen. Seems that “auto_armed” corresponds to throttle up after arming; it appears also with the copter very high and may correspond to trying to recover control;
*at descent high vibrations appear after CTUN.ThO is above 0.5, but increases when it gets lower.

Could happen that V3.6.8/NuttX is a dangerous version (at least requires tuning); vibrations are not so high before descent. Why the sudden ascent?

1 Like

Yes, you are right. Vibration have to be solved but is that the reason of ascending continuously?

Webillo is right: while you have more vibration than one typically would like, and you have very severe prop wash oscillation when descending, your actual problem (floating up uncontrollably) has nothing to do with vibrations.

You can see from the logs that the quad knows it is ascending and also that the throttle is zero. This can only happen in 1) Auto mode or 2) RTL. Are you sure you were in AltHold? Are you sure all failsafes, GCS, throttle, battery, etc are disabled? If so, you have a firmware bug and you should try flashing the Pixhawk with the latest Arducopter / ChibiOS, or one version back.

Servers by jDrones