Servers by jDrones

First Flight Octacopter - Crashed

(Ron E) #1

I am hoping someone can give me advice on what to look for. I have spent weeks after the build calibrating and checking everything I could. I calibrated the compasses multiple time with success.

I took off in Loiter mode and got to about 5 feet when the copter started climbing although, I lowered the throttle all the way, it continued to climb while starting tilting and rolling in all directions. A crash was imminent! I switched to stabilize and was able to bring it down but not before my hear rate climbed over 130!

I have tried to understand what to look for in logs but have had limited success.

The build is:

  • Tarot T18
  • Tarot 5008 kv340
  • CUAV Pixhack V5
  • 2 x CUAV GPS
  • 2 x 6s 6000 mah

I know there are infinitely more knowledgeable hobbyists and pros who may be able to give me some insight. I have included some photos, the video and the flight log.

Thanks,

Ron

Flight Log

Flight Video

![IMG_4461|375x500]

(hans bert) #2

i will have a look at the log tomorrow :slight_smile:
looks fixable, good that you got it down in one piece.

my guess, too less weight, too high mintrottle, or Z vibrations :slight_smile:

(Ron E) #3

The takeoff weight is 7.03 kg.

I am leaving the gimbal and camera off until I can get a stable flight

(Harald Schmid) #4
  1. most important you have chosen the wrong frame type!
    You do not have a „frame type plus“, you have „frame type X“
    You need to change the paramter FRAME_TYPE from 0 —> 1

The following points could help for a further step but perhaps are not necessary after you choose the right frame type

  1. you should damp your FC better. VibeZ with 60 is too high

  2. copter is overshooting in Roll and Pitch
    Reduce ATC_ACCEL_R_MAX 110000 —> 60000 and
    ATC_ACCEL_P_MAX 110000 —> 60000 and
    ATC_RAT_RLL_P 0.135 —> 0.08 and
    ATC_RAT_RLL_I 0.135 —> 0.08 and
    ATC_RAT_PIT_P 0.135 —> 0.08 and
    ATC_RAT_PIT_I 0.135 —> 0.08
    Then start to manual tune PIDs or do Autotune

  3. reduce MOT_THST_HOVER from 0.6875 —> 0.3 and then let „motor hover learn“ start from that value

  4. reduce MOT_SPIN_MIN from 0.15 to 0.11 to have more control at the bottom ending

(hans bert) #5

yea change the frame type, nothing else. testflight. and if this is fine. go on :slight_smile:

(Harald Schmid) #6

And please give feedback if it is solved

(Ron E) #7

First let me say a big THANK YOU to Harald for his magical analysis. I applied all of your recommended changes and, after a number of minor crashes, I got a somewhat fairly stable flight. It is rather sluggish on the throttle and Yaw but, I expect that has to do with the PI parameter changes. It is still not flying properly in that, it tends to rock back and forth when pitching and rolling. The auto analysis shows the motor balance is not good. Not sure how to fix that?. Also, Attached are the 2 flight logs which, if you have time, I would greatly appreciate understanding the rocking back and forth as well as the motor balance.

On a separate note, I am comfortable making changes in source code [Bell Labs background] (not EKF related - mostly sensors); however, I have read everything I could find on log analysis and, your ability is far beyond anything I have seen. Can you recommend an approach to learning or do you provide tutoring :slight_smile:

First Flight
Second Flight

Once again, I cannot thank you enough. I have been working on this build meticulously for a very long time and did not want to crash it on the first day :smile:

(Harald Schmid) #8

Hi Ron

A) Good to hear that you got it in the air. Now let autotune do the job.
See here: http://ardupilot.org/copter/docs/autotune.html

Important:

  1. Set autotune-aggr to 0,05. you can repeat Autotune later with 0,075 or even 0,1. But in the beginning less aggressiveness is better.
  2. Set the Rate Roll and Pitch filters to 10hz

You can also manual tune with CH6 option. See here: http://ardupilot.org/copter/docs/tuning.html?highlight=tune
This wobbling back and forward could be a too low D-value. You need to try

B) Concerning the motor balance:
Motor 1,2,7,8: average:1280 (very consistent) Clockwise
Motor 3,4,5,6: average: 1415 (very consistent) Counterclockwise

2 possible reasons:

  1. your motor mounts are not 100% horizontal. Check that the end of the props are at the same height as the neighbor prop. You can also measure the height of both prop ends from the floor if they have 90 degrees to the arm. Should be the same distance to the floor.
  2. Different geometry of the CCW props (in my experience this is the problem). You can check if you do the motor test in mission planner with 20%, 40%, 60% output per motor and measure the current. If you see less current on the ccw props then they create less trust with the same output

BR

Harald

(Ron E) #9

Thank you. Will give it a try over the next couple of days. Any recommendations on how to learn log analysis at a much deeper level.

(Harald Schmid) #10
  1. Reading in this Forum
  2. Asking people here, there are many very helpful guys here
  3. reading this material: http://ardupilot.org/copter/docs/common-logs.html
  4. Selfstudy
(OldGazer) #11

#1. (people are gonna push back on this but I don’t care.) NEVER, EVER, NOT EVER TAKE OF IN LOITER FOR A TEST FLIGHT. You need to make sure the aircraft will fly in Stabilize before you go messing around with GPS assisted flight modes. Once you are sure the aircraft will fly in Stabilize, you can test AltHold. Speaking of AltHold, You couldn’t control throttle because AltHold is active in Loiter, and Alt Hold puts a “dead band” around Hover Throttle…

#2. Make sure the aircraft is balanced in roll and pitch. This includes placing the batteries so they are both parallel to each other and the aircraft roll axis.

#3. Figure out which end of the aircraft is the front and make sure both GPS/compass units are on the aircraft centerline and pointing forward and then recalibrate the compasses.

#4. Motor imbalance can be caused by a combination of aircraft imbalance and motor alignment. Based on the numbers and the aircraft behavior IMHO ALL of the motors are out of alignment. You need to make certain that all off the motors are square with the frame.

2 Likes
(Ron E) #12

@OldGazer Thank you - I have learned my lesson about taking off in Loiter mode as a first flight! I have calibrated the compasses successfully. I have 2 GPS units one in front pointing forward and one in the back pointing backwards with a yaw rotation of 180. In MP, all 3 compasses are checked as being used and not checked as externally mounted. Do I check externally mounted and disable #3? I am thinking of raising the batter mount plates as both plates push against the FC which I believe may be increasing my Z vibrations? For the motor imbalance, as @Harald, mentioned, it might be my props. I just received a more matched set which I am hoping will help.

(Corrado Steri) #13

Are the compasses canbus? I am asking because i know Cuav was releasing a canbus gps/compass.

If they are not they should have been picked up as external by the system as compass 1 and 2. If no external compass is picked up by the system it means you are using the internal ones.

(Ron E) #14

Unfortunately, not. I wish they were.

(OldGazer) #15

.[quote=“rge99, post:12, topic:44508, full:true”]
@OldGazer Thank you - I have learned my lesson about taking off in Loiter mode as a first flight! I have calibrated the compasses successfully. I have 2 GPS units one in front pointing forward and one in the back pointing backwards with a yaw rotation of 180. In MP, all 3 compasses are checked as being used and not checked as externally mounted. Do I check externally mounted and disable #3? I am thinking of raising the batter mount plates as both plates push against the FC which I believe may be increasing my Z vibrations? For the motor imbalance, as @Harald, mentioned, it might be my props. I just received a more matched set which I am hoping will help.
[/quote]

The external compasses must be checked as being externally mounted. You can leave the internal compass enabled.

The motor imbalance could very well be the props, but in my experience motor alignment and
static balance are the major contributors. Additionally, motor misalignment will also contribute to un-commanded yaw with is particularly evident during the first take off before doing an AutoTrim.

How do you have the flight controller mounted to the frame?

(Ron E) #16

The flight controller is mounted on top of Kyosho vibration absorption sheet on top of a Lucite plate mounted to the center of the frame as pictured.

IMG_4473 IMG_4472

(Ron E) #17

OK - I ran AutoTune on it twice. It doesn’t bounce back like it used to which is better but on this last flight, the whole flight it was shaking and Yaw was very sluggish to the point of almost not responding. As I was trying my third attempt at AutoTune it started Yawing continuously while still tuning roll. I believe the PIDs which I started with were better in terms of control. I have attached the latest log and image of the current PIDs. Any advice would be greatly appreciated as I came very close to crashing.

Log After First AutoTune
Log After Second AutoTune

After tuning…

(Jeff) #18

@rge99

Ron - have you read thru the new tuning instructions in the wiki? I found them very useful in determining where my parameters need to be PRIOR to autotune. They may save you from having to do multiple autotunes.

http://ardupilot.org/copter/docs/tuning-process-instructions.html

(curt carroll) #19

I am not sure this will fix your flight issues but the Yaw did not auto tune. It’s my understanding that you must land in auto tune mode to save the tune. I see you have shut the 2nd tune off prior to disarming.
Your compass looks ok but lithium batteries are magnetic. The battery placement would concern me because of that. Also: The balance and the tendency to roll hard is increased by the weight being higher.

1 Like
(Ron E) #20

Thanks for the responses and suggestions. My concern is how to get back to the original settings which were flyable w/o having to do a full reset or do an auto tune again with PIDs which make it flyable