Servers by jDrones

Finally Spilling the Beans on RTK GNSS


(Andrew W Morgan) #21

While this is true and I did use a Here+ Base as a rover, it requires soldering in wires to break out the serial output which is not an easy task given the amount of ground plane on the pcb. This one of the reasons why I say the TinyRTK is my current favorite M8P board as it has all the right connectors and doesn’t require any soldering.


(Andrew W Morgan) #22

Ublox m8p v1.4 firmware is out!!!


(proficnc) #23

Hi Robo_Roby something that you may be interested in, the M8P can output all the raw data you need for RTKLib, It would be very interesting to compare the results of running RTKLib on the M8P and compare the results…

Also for mission planner users of all the m8P based systems, a pull request has gon in to fix a bug in 3.5 that could possibly be affecting the ability to maintain an RTK Fix


(proficnc) #24

Looks like you need to invest in a decent soldering iron!!!

How this group has changed! Soldering three pins!

As the power still needs to come from the USB connection you can get away with just the two pins if you want…


(Andrew W Morgan) #25

Attacking the customer is always the professional response.


(Gertjan973) #26

Where can I buy a k501g module for 900 USD?


(Robo Roby) #27

@gertjan973 Contact ComNav directly


(Andrew W Morgan) #28

FWIW, this is what I was told…

I was also told I couldn’t buy just the K501g boards even though I’m 99% sure I don’t need the interface board or their antennas.


(Robo Roby) #29

@Prototype3a You only need the boards. Board output is serial and antenna can be purchased cheap on ebay/Aliexpress. If ComNav won’t play nice, I’d be tempted to contact Unicore (UB352) for L1/L2 GPS/GLONASS (600 USD last price I heard). Alternatively the M8P is getting quite good – at this point you’ve got options.


( research air) #30

Hi, has anyone been able to load m8pv1.4 firmware I tried and failed and now can’t load messages,I think fis file is missing and I can’t find it anywhere, any help would be great…thanks in advance


(Andrew W Morgan) #31

Sorry that I just saw this… maybe you’ve already sorted it.

The FIS file is in the Ucenter program folder (at least on my windows machine). That one threw me for a loop as well.

For what it’s worth, our lab has been playing with the Swiftnav Multi lately and my conclusion is that the Multi is very optimistic on claiming that it has RTK Fix where the Ublox seems to be extremely conservative and won’t claim Fix unless it has had consistent and stable fix solutions for many MANY seconds. I believe Ublox datasheets say something like 30 seconds where the Swiftnav seems to claim Fix after maybe just 2 seconds.

Either way, I’ve seen both systems work and totally not work depending on location, if you’re standing just right or the alignment of the planets. Neither has been reliable or a state that I would consider “deployable”. The only major upside to the Ublox that I’ve seen is that it doesn’t do anything stupid when things aren’t working properly. It very smoothly and seemlessly falls back to either single point position solution or RTK Float.

I still really want to play with a ComNavTech but I doubt I’ll be able to get funding for that adventure.


(Andrew W Morgan) #32

We got our hands on a Harxon HX-CH4601A helical to use with the Swiftnav Multi and it seems to perform very similar to the Maxtenna helicals but at around half the cost. The shipping from … Taiwan?.. was very expensive so I would order a few at a time if you need them or try to negotiate a cheaper shipping method.

My contact at Harxon was jinmingyang@harxon.com


( research air) #33

thanks, not yet but will look as instructed
http://navspark.mybigcommerce.com/ns-hp-rtk-capable-gps-gnss-receiver/
have you worked with this ???
Rick


(olive gak) #34

Hi Robo_Roby

have you ever tried to integrate a Unicore UB352 or a ComNav K501G with a 3DR Pixhawk ?
I plan to do PPK with a L1/L2 board which will replace the standard Ublox M8N.

Thanks in advance


(Robo Roby) #35

Yes, I’ve used the K501G with a Pixhawk. It works great – uses Novatel driver written by Michael Oborne.

No, I have not used a UB352. Would love to hear feedback from someone who has. I suspect (but have not confirmed) that DJI uses Unicore boards for their RTK kit (https://www.dji.com/d-rtk).

Keep in mind that the u-blox M8P is a very solid contender if you can accept L1 limitations.

Also, RTKLibExplorer has lately written about PPK with u-blox M8T boards.


(olive gak) #36

Hi Robo_Roby,
thanks for your answer. I often work in areas far from the CORS station (15 to 35 km). That’s why I think a L1/L2 should be more efficient.
Can you tell me more about the K501G integration with a Pixhawk ? Did you replace the original GPS ? How do you collect raw data for post processing ?


(Robo Roby) #37

Have written about configuring the K501G here

Once you’ve got the K501G outputting the PVT data on a port, you just wire up that port to the Pixhawk’s GPS–>RX

It’s worth noting that the ArduPilot’s Novatel driver has code to attempt to automatically configure the GPS card at startup. Back in the day when I was setting up the K501G on a PixHawk, I was having problems with this dynamic configuration at startup, so I just pulled the wire (i.e. I’ve only got a wire connecting K501G–TX to PIXHAWK-GPS-RX). But when you do this, you also lose PixHawk’s nice ability to forward RTCM corrections on to the card (I have a separate radio dedicated to RTCM corrections and relay those corrections on to the card).

I’ve only used this setup for RTK – haven’t had a need for PPK.


(Andrew W Morgan) #38

I found this article yesterday and it sheds some light on the performance I’ve seen.

As another datapoint, I’ve been told that the Septentrio AsteRx-m2 UAS C is ~$6k but I’ve seen it sold integrated for less so my best guess is the board is $3500 with volume discounts.


(Jason Brindle) #39

Hello, I am not sure if you are still following this Blog, but I would be very grateful if you could provide some advise/help on connecting/setting up the ComNav oem boards with Ardupilot.


(David) #40

Go to his website. He posted a detailed how to guide there