FFT Filter Tool Upload Issues

Hi all, me again with some filter tool testing -

I’ve been very interested in the Arducopter Filter Review tool recently. (Thanks @iampete ) I was able to upload some batch logging logs the other day to the tool, but today I tried it with Raw IMU logging on a H743 Matek Slim, and trying it in a couple browsers, Chrome and Firefox, I get an error that doesn’t allow the log to load correctly. These logs aren’t that large, relatively, so I’m not sure where the issues lies in the upload.
Logs are here - Sign in to your account

Here are some screenshots of the errors. I can raise an issue on Github as well as it requests once I figure out how to do that. I have tried reloading the web page multiple times and/or opening a new tab/restarting the browser, etc. Thanks for any light anyone can shed on this.

Thanks for the report, I have just pushed a fix. It should go live in 15 mins or so. You will have to hard-reload to make sure you get the new version and not the old one from your browsers cache.

If your interested this was the fix, you must be the first one to try raw logging with 2 IMUs, it worked for 1 and 3. FilterReview: bug fix by IamPete1 · Pull Request #41 · ArduPilot/WebTools · GitHub

Thanks for the quick response and fix! I’m really enjoying the tool, thanks again for your work on it. :+1:

hello everyone although the error is not the same I wanted to report this problem that I get when I try to upload my log .


I only activated RAW_IMU in the LOG_BITMASK. Thank you all for the help

Thanks for the report, I have just pushed a fix.