FFT didn't perform as expected

Hi all,

I used the Measuring Vibration with IMU Batch Sampler thread to setup parameters to perform an FFT. In analysis, when I click IMU Batch Sample no graphs show up, but FFT IMU GYR and FFT IMU ACC output some junky graphs (in domain 4-12Hz!?) when I click Run All IMUs. I configured sampling to take place at 1000Hz because I have a large hexarotor and thus don’t have IMU_FAST checked in my Log_Bitmask. Could either of these be the reason I can’t run a batch sample/have low resultion in my FFT graphs? I have heard 4.3 has FFT improvements so if my issue could be solved with an update I can do that.

LOG: https://drive.google.com/file/d/1XHwx474Op-h33zJlVxR5jAg8srueUMsv/view?usp=share_link

The whole point of this process is because my tune is loose and has a lot of noise in the Aquired.Roll/Pitch signal. This causes position hold to be unstable so I am trying to calibrate my filters to improve my tune. If anyone sees anything else in the log I am missing that would be greatly appreciated.

6ft diam hexarotor
Approx 30lbs
30.2x9.9 Tmotor props
Tmotor U12II motors

Update to latest Stable. There are some important updates you want. Option 4 is not recognized in that old version (INS_LOG_BAT_OPT,4)
Set the log bitmask back to default.

After setting the Notch filter settings change Auto Tune aggression back to default (0.10) before running it again so you don’t repeat this:

1 Like

This worked! Thanks @dkemxr

For anyone reading don’t forget to update Mission Planner too.