Servers by jDrones

Fence is unavailable to write to pixhawk 2 when use 915MHz data transfer on QGC

When I use 915MHz to write fence to pixhawk on QGC, get error. But if use USB cable, it works. I have to link a USB cable to test rover follow rover running.
When switch to 915MHz transfer/receiver, the fence feature is gone. It looks the fence is not written to pixhawk 2.
How it works fence feature on QGC using 915MHz transfer/receiver.

My guess would be that you radios are using older firmware which does not support Mavlink V2 protocol. Fence/Rally requires Mav 2 protocol. Also make sure you are using Daily builds since there are many fence/rally fixes in there. You need to flash your radios with latest firmware.

… also maybe try setting the appropriate SERIALx_PROTOCOL = 2 (for MAVLink2) where “x” is the serial port number. so for example, if the radio is connected to “Telem1” then modify the SERIAL1_PROTOCOL.

Thanks for the report!

We tried Mavlink 2, it is same issue.

ok, it’s probably what Don says, the radio itself doesn’t support mavlink2.

Also I have found cases where I had to once connect to the vehicle using mission planner and then after that if I connected with QGC, the fence feature worked.

yes, I tried same thing, draw the fence in QGC, then back to mission plan using radio. some time works, most time does not.

@lumono,

If this is a SiK radio could you try updating the firmware on it? It should be possible to check if it’s a SiK radio by pressing the “Load Settings” button on the page below (if it connects and displays values in the various fields then it’s a SiK radio). Note that you may need to set the COM port drop-down, baud rate and it may even be necessary to check that the “connect” button is in the disconnected state. Sorry for the slight unclear details, I haven’t updated the firmware myself on too many radios.

I will try it, thanks a lot.

1 Like

If you run latest QGC daily builds and turn on VehicleLog (https://docs.qgroundcontrol.com/en/SettingsView/console_logging.html) it should tell you what is going on with respect to vehicle capabilities and mavlink 2 protocol negotation. Older daily builds have similar logging, but there is more information in latest dailies.

I found the problem that is MavLink choice RawData, not MavLink.

@lumono, are you saying that if you chose “RawData” it works, but if you chose “MAVLink” it does not work? I think this adds to the evidence that it’s a MAVlink1 vs MAVLink2 issue and perhaps the software on the radio doesn’t understand MAVLink2. It should be possible to upgrade the firmware on the radio using MP.

I updated firmware by http://firmware.ardupilot.org/SiK/stable/ radio~hm_trp.ihx in MP.
chose “RawData”, then goto QGC, it works. If chose “MavLink”, QGC shows error.

@lumono, and setting the flight controller’s SERIALx_PROTOCOL = 2 and then the Radio’s MAVLink drop-down to “MAVLink” also definitely doesn’t work?

This suggests that it’s a radio issue but the latest Sik firmware should support mavlink2.

FenceDoesNotSupport

still shows your vehicle does not support Fence in QGC latest version.

0

after 60 minutes, open QGC again, it shows the Radio uses MavLink v1.0.

What is latest version of Radio firmware.
http://firmware.ardupilot.org/SiK/stable/radio~hm_trp.ihx
Is it correct?

update firmware (local) in MP, The error "Detected radio still using MAVLink v1.0 … " is gone, but it still shows this vehicle does not support GeoFence.

I really think this is a QGC issue. Maybe it will be resolved if we default all the mavlink protocols to “2” but I think this is what you’ve already done if you’ve set the SERIALx_PROTOCOL = 2.

Installed daily build QGC, it still shows my radio firmware is MavLink1.0, Fence button is enabled.

I’m not sure but I’m pretty sure it’s a QGC issue. Maybe post an onboard log file (or a parameter file) and tell me which serial port you’re using so i can confirm that port is configured for MAVLink2.

Looks like there is a bug in QGC if you are using a SiK radio which is not running PX4 Radio firmware. It sends the radio status packet using mavlink 1, which in turn confuses QGC and causes it to flip back to Mavlink V1. This will get fixed in the next couple weeks before QGC 4.0 goes stable.

1 Like
Servers by jDrones