Feature Request Follow Me Guided

This should be available in Daily Builds now.

I will test it as soon as the rain stops.
Is it in the Android version too?

It’s in all versions

The rain is gone and I have made a test with the Android version.
The google play daily version does not have the new features (it is from 2019/9/17), only the apk does.
Configuring follow me works great.
But at the field I could not switch to “follow”, neither from qgc nor from the transmitter.
Also “take off” did not work.

Unfortunately the log upload does not work, the log file is here

Dataflash log

Yeah I just discovered that the Daily Build stopped updating a few weeks back. The links from the docs do work as I think you already discovered.

Not sure that this means? Need exact steps and the point where something went wrong.

Same thing, “did not work” could mean one of a million different problems. Need more detail.

“did not work” could mean one of a million different problems

I know, unfortunately there are no telemetry logs, see here

I can’t see any errors in the dataflash log.

Could not switch to follow:

  • Follow doesn’t show up as a selectable flight mode in the toolbar?
  • Follow does show up in the toolbar list but you selected it and absolutely nothing happened?
  • You selected it and you got an error?
  • You selected it, the flight mode changed in the toolbar changed to follow, but follow did not work?

Same thing for takeoff…

#2 nothing happens

same when follow send by transmitter

Does you firmware have FOLLOW_* parameters in it. You might not be running a version which supports it. Not sure what version that showed up in.

It’s ArduCopter 3.6.11, the actual version.



Those parameter settings are all good. You’ll have to ask the firmware folks why it isn’t working.

I have made another test.
Follow works if send by the transmitter.
In QGC I cannot switch to any flight mode.
After take off, flight mode is guided, selecting any other
flight mode from the menu does not change the flight mode.

Parameters download correctly and you don’t get any errors from that? Seems like the QGC->Vehicle comm direction isn’t working correctly. When you change flight mode from RC does it reflect in QGC?

Yes, parameter download does not give any errors.
Changing flight mode from RC is reflected in QGC.

I have to tap on the flight mode several times until the menu pops up.
Also the menu looks weird. After popping up it reduces its size.

This is only related to Android, the Windows version seems to work.

Ah, ok. There was a bug in the flight mode control ui which was fixed yesterday. You may be hitting that. A new daily might fix it if that’s the problem. Also I’m currently fighting with new requirements on the google play store. So best place to update latest android is from the Daily build APK link in the docs. But keep in mind you won’t get auto-update from that.

Looks better.
In version 2019-10-08 I can switch flight modes.

I haven’t flown in follow mode yet.

There is an item in the menu bar which is not fully visible.
I guess it’s Arm/Disarm.


I have just flown the quad.
Flight mode change worked.
I could switch to follow mode although it didn’t work at all.
The quad tried to attack me, lost altitude and landed.
I think this should be a firmware issue.

What was your Follow setup. Did you use the QGC Follow page to set it up? If so, can you take a screen shot of that and also a screen shot of the FOLLOW_* parameters?


Yes, those values seem valid. The drone should have stayed 8 meters above you. Which does seem like a firmware problem.