Servers by jDrones

FBWA etc control compensation direction

(mpjf01) #1

Just upgraded from 3.7.1 to 3.8.2. The elevator compensation in FBWA and Stabilise etc is the opposite of what it should be and I need to reverse it. I have searched the Wiki, that tells me to check that the direction of compensation is correct but does not tell me what to do if it is not. There used to be a parameter that I changed to set this direction but now I cannot find it. Everything I do try either does nothing at all (the tick box in Mission Planner) or changes the primary control direction, not the compensation. Can someone who knows remind me what the method of changing it is please. Thanks.

(lucamax) #2

You must change the servo parameter “reverse”

(mpjf01) #3

I did that and it reversed the direction of the control surface in manual mode, not the compensation in FBWA.

(mpjf01) #4

I have repeated the process of changing this SERVO3 setting, making sure that I saved the change and rebooted the FC. The change reversed the direction of the travel of the elevator in response to transmitter stick control, but the compensation response was still the reverse of what is required. I have set up the elevator to move correctly as per the radio calibration page in Mission Planner. I expect that in FBWA mode the elevator will be automatically moved to an UP position if I push the nose of the aircraft down, this is what it used to do before the upgrade. Instead of this the elevator moved to a DOWN position which would obviously make a dive worse and is not what is required. The process of remedying this used to be described in the old version of the Wiki and was easy to accomplish, now it is not described as far as I can see and I cannot fly the aircraft until I can fix it. Is reversion to 3.7.1 the best option for me?

(lucamax) #5

What kind of plane do you have ?

A flying wing ?

(mpjf01) #6

No, a normal aircraft with no ailerons- rudder only.

(lucamax) #7

With 3.8 the strategy of servo outputs is totally changed .

I suggest you to try to modify RCX_REVERSED and SERVOX_REVERSED , I had a similar problem with my flying wing and it worked.

Check also RUDDER_ONLY parameter.

(mpjf01) #8

I have already tried all 4 combinations of RC3 and Servo3 reversed. Each does what you would expect with the primary control direction but the compensation remains the opposite of what is needed. The Rudder Only parameter is already set and the rudder servo is plugged to servo4 position. However it is the elevator that I am having the issue with, the rudder works as expected and the compensation is in the correct direction.

(lucamax) #9

How is configured your RcMap ?

(mpjf01) #10

In previous firmwares there was an explicit method for altering the compensation direction and a section of the Wiki explaining how to use it. Both of these have been removed and I am trying to determine what they have been replaced with.

(mpjf01) #11

Set to JR/Spektrum standard TAER

(Jakob Thrane) #12

Reverse servo direction in transmitter. Calibrate radio in Missionplanner making sure that bars are moving the right way (Same way as sticks, except pitch, that should move opposite stick direction). If not, reverse them right on the page where you calibrate transmitter in Missionplanner. Check if servos move the right way in manual. If not, reverse the servos that turn the the wrong way in the SERVOn_REVERSED parameter. Now compensation in FBWA will be correct.

(mpjf01) #13

Thanks for that, problem is now resolved.