AR Wing PRO, TX16s and Pixhawk4-mini: elevons or aileron/elevators?

Hi all,

I’m in trouble trying to configure my AR Wing PRO… I can either set it working in the right way when using the radio OR for the autopilot… but not both.

As far I can see, my problem has already been discussed here, here here and here.… and I’ve try to follow what suggested there but didn’t work for me.

Initially I’ve followed what described in Four Channel Planes but it did not work… I’ve been able to control the radio using the TX16s but no way to let the Pixhawk to control the elevon/aileron in the right way in FBWA mode. TX16s is configured for elevon mixing as described here and

Then I’ve followed what described for Elevon Planes and I’ve got the opposite… Pixhawk controlling the mobile surfaces in the right way but TX16s not.

I thought that by setting RCMAP_X I could solve the problem but it didn’t work either… I can reverse whatever I want but I cannot let the TX16s to move the ailerons at the same time for pitch control.

Here are my current TX16s and MissionPlanner configuration

I’m probably mixing configuration for old and new ArduPlane or for fixed-wind and delta-wing… but I can’t really get out from this mess :frowning_face:

Any help will be really appreciated!

Best Regards,


Hi Giampaolo,

First you configure the flight controller; make sure your SERVOn_FUNCTION are correct (elevon left, elevon right), put the aircraft on FBWA, move it around and check if the elevons are going in the right direction to stabilize the aircraft. If they’re not use SERVOn_REVERSE to correct the direction of movement.

Once the FC is configured you can move to the radio controller; create a 4 channel airplane (THR, AIL, ELE, RUD) and make sure these four radio channels are correctly mapped to the FC via the RCMAP parameter. After this move the plane control surfaces using the radio; if they’re going the right way to control the aircraft, great! if not reverse their direction at the radio (personal choice).

Hope that helps.


1 Like

Just to add what @C.Young said, don’t do any mixing or trims in the TX16S. Just leave it as a 4-channel output. The flight controller will take the aileron/elevator inputs from the radio and convert that into elevon outputs, even in manual mode. Arduplane defaults to AETR mapping, but you can change that if you need to.


Hi Charles, Allister,

thanks a lot for your support…

When you talk about 4 channel, are you referring to something like this ?

Sorry but I’m not sure about the number of aileron, the tail config etc…

mmm… it seems that this setup is creating a MIXING… so it’s probably wrong…

thanks again,


Nope, in the radio, all you need is throttle, aileron, elevator and rudder. DO NOT configure the radio with aileron/elevator right/left. As Allister said, the elevon mixing is done by the FC.


I can’t figure out how to get it using the tx16s wizard… I’ll try from the companion app.


The wizard isn’t much use. I just create a model and to the rest myself.

Here’s my AR900 wing. Don’t mind channel 9, I was tinkering with something along the way.

1 Like

I’ll try to reproduce this manually… thanks!

at the moment I’ve try 3 different setup using tx16s wizard and Companion 2.3 and in all cases I end up in having some kind of mixes…


If you’re used to “traditional” RC, this is a different beast. All the FC needs to see is the four distinct stick inputs, then Arduplane does all the heavy lifting. If you’re used to using your trim switches then I would also disable those so you don’t get into any trouble down the road. SERVO_AUTO_TRIM,1 will take care of that for you.

Not sure about the “traditional” RC meaning… I’m using a TX16s w/ SBUS… on the radio side I have two RFD868.

RC airplanes without flight controllers.

Hi Allister, Charles…

it works! thanks a lot for supporting me, really !

I’m probably close to my maiden fly… and I must say that It has been a big challenge!

These are my first steps in RC model and I had to learn a lot… TX16s, Yaapu script, Companion app, RFD868, Mavlink, MissionPlanner, QGroundControl, Pixhawk etc etc were all new to me and getting stared has been quite an effort.

Thanks also to all the developers for these great software and firmware… I’m really impressed by the possibilities offered by Ardupilot & Co…

1 Like

You certainly went head first into RC! It’s a very, very steep learning curve for what you’re trying to achieve.

Don’t forget to set SERVO_AUTO_TRIM to 1 like Allister said and make sure to quadruple check you’ve got the Center of Gravity in the right place - the AR Wing Pro is notorious for needing lots of weight up front to get the CG right.

Good luck on your maiden!