FBWA compensation is REVERSED/WRONG for Elevator

I have read several topics about this issue but none seem to solve my problem.

I am using:
Arduplane 3.8.5
Pixhawk
Taranis 9 Plus
Bixler 3 aircraft

Current behaviour:

  1. When I pick up the aircraft and move it, the Mission Planner HUD display moves correctly.
  2. When in Manual mode, all controls move in the correct direction given User input
  3. When in FBWA mode, all controls move in the correct direction given User input
  4. But in FBWA mode, when I pick up the aircraft and move it, the ailerons compensate in the correct direction and the Rudder does not appear to move. BUT the Elevator moves in exactly the Wrong direction.

Notes:

  1. None of the channels in the Taranis are reversed.

  2. In Mission Planner under Calibrate Radio, Rudder/Yaw and Throttle are reversed

  3. In Mission Planner Full parms List, Elevator and Rudder are reversed.

  4. When I reverse the Elevator in only the Parms list, Manual, FBWA controlled and FBWA compensation are all wrong.

  5. When I reverse the Elevator in only Calibrate Radio, Manual, FBWA controlled and FBWA compensation are all wrong.

  6. When I reverse the Elevator in the Parms list and Calibrate Radio, Manual, FBWA controlled and FBWA compensation are all wrong.

Essentially, nothing corrects the FBWA compensation direction.

After countless iterations of changing the reverse flags in each of the 3 areas, I cannot find the solution.
Is there a magic parameter which I am missing?
Please help.

2 Likes

Check for servo calibration/servo output tab above the radio calibration option.Try reversing from there. There are options to reverse operation of the servo only from there instead of the RC channel.
In the params list, did u change SERVO2_reversed or RC2_reversed??

Thank you Karthik_A! You mentioned “SERVOn_reversed” and I had completely missed that parameter.
THAT was the solution!!! Yes. Now all control surfaces move in the correct direction when in Manual, FBWA, or moved by hand under FBWA.
So now on to final checks before the FIRST flight in Manual mode only.

1 Like

Super. All the very best. Let us know how she flies!!!

I am now convinced that missing this parameter and stupidly not checking the compensation directions was the cause of the fatal crash of my Ranger Ex last year.
It was on its 4th Manual flight and then I switched to Autotune and it instantly went straight down at 94 kmh; not a pretty crash site!!

I have just put in a pull request to change/update the wiki where we talk about setting up planes. You’re not the first user to have double-reversed inputs and outputs that appear correct in manual mode… but destabilize in FBWA and other modes.

The new setup procedure should prevent this from starting in the first place.

2 Likes

Nathan; Great idea! Thanks

This is awesome. Would it be helpful to define a ‘standard’ channel for a 5 channel plane? Is there a standard channel recommended/defaulted for 2nd aileron channel?

Also - I don’t know if this is doable, but is it possible to have the 2nd aileron output implemented in the flight controller without using an RC input channel? i.e. Transmitter only sends one output for ailerons, but FC maps to 2 outputs (one reversed).

If the RC in is set to ROLL, any Servo with fuction “Aileron” will respond to that single input channel. Set Servo5_function to aileron and it will do the same thing as Servo1. You can trim it individually using the other Servo5_ parameters.

1 Like