Servers by jDrones

Failed to connect to SITL instance :(

Running Windows 10 Mission Planner and getting a “failed to connect to SITL instance.” It was working fine a few hours ago. Anyone run into something similar and have a fix? Thanks

1 Like

Hi Shane I am experiencing the same issue. It was working fine two hours before and now it says failed to connect to SITL instance.

@Michael_Oborne : Need your help

more info.
what sitl? copter/plane/rover

1 Like

@Michael_Oborne

Tried clicking on Copter, Plane and Rover but all throws "Failed to connect to SITL instance " errror after showing “downloading SITL software” window

Yep. Same for me as Jawad.

I’m still having issues. Can someone on the forum confirm that SITL is working for them? That way I know at least these issues are mine and not the firmware?

1 Like

Not working for me :frowning:

its working for me again now

1 Like

Thank you…

Installed windows 10 in Virtual box and tried simulation there… works perfect

Fresh win10 and win7 - sitl doesn’t start anymore.
I run Simulation in MP. After downloading process I can see sitl window opens and immediately closes. MP reports Failed to connect to SITL instance, after that.
It always worked before.
Latest MP.

I just had a quick test, is working for me, MP latest beta (altogether it shouldn’t matter, the bug was in AP not MP).

No luck for me.
Do you use windows?

How can I start sitl manually? To see the error.

Yep, Windows 10.

Try deleting your Documents/Mission Planner/sitl folder

Deleting didn’t help.

I’ve started sitl manually.
It didn’t get connected

D:\My Documents\Mission Planner\sitl>ArduPlane.exe -M PLANE
Starting sketch ‘ArduPlane’
Starting SITL input
Using Irlock at port : 9005
bind port 5760 for 0
Serial port 0 on TCP port 5760
Waiting for connection …
Connection on serial port 5760
setup:332: bad header in setup - erasing
0 [main] ArduPlane 10028 cygwin_exception::open_stackdumpfile: Dumping sta
ck trace to ArduPlane.exe.stackdump

Exception: STATUS_ILLEGAL_INSTRUCTION at eip=005B19FB
eax=00000000 ebx=00000001 ecx=00000004 edx=00000000 esi=00000000 edi=00000001
ebp=00643920 esp=0028CA90 program=D:\My Documents\Mission Planner\sitl\ArduPlane.exe, pid 10028, thread main
cs=0023 ds=002B es=002B fs=0053 gs=002B ss=002B
Stack trace:
Frame Function Args
00643920 005B19FB (00064150, 00000000, 00000000, 00000000)
00690A10 00000001 (005B16A0, 005B1940, 005B17C0, 005B1D60)
005B1D50 0058C330 (90909090, 90909090, 08EC8353, 10245C8B)
End of stack trace

Same problem Quad>multicopter, downloads then fails to connect. Tried deleting the SITL folder that made no difference. I’m using Win7 - even checked to see if it was fired walled out.

Same for me. Windows 10, quad Multirotor. Also plane and rover fails. Latest Mission Planner 1.3.73. Worked about a week ago, now failed to connect.

In the past, it was a problem with the server, that usually was fixed after a short time but now it seems to last since 4 days already :frowning:

@Michael_Oborne
I still have the same issue, please i need your help

Mine was working great last week. Windows 10, latest version… Why would it suddenly stop working?

https://github.com/ArduPilot/ardupilot/pull/15332 should fix this issue

I checked the link, but I’m not a programmer by any stretch of the imagination so I am absolutely clueless as to what is going on there. Is it a setting or some sort of Linux command?

Servers by jDrones