Failed to change to loiter mode -- "Requires position"

Hi Shawn,

Sorry for the trouble caused to include your original text. In fact, I used large font and different font to make reading easier,

probably it was reformatted after transmission. See attached screenshot for my original text.

Yes, the Pixhawk is a clone. I am aware of this voltage level of Vcc and am not comfortable about it, but thought

it is not too much lower than 5V and may not cause much trouble. Adding capacitor is a good suggestion.

For ESC BEC voltage, since there is no servo connected to output, I should remove the 5V red wires from 3 BEC cable,

leaving 1 BEC to supply +ve voltage to complete the circuit with ground, right ? Pls confirm.

Will replace the relevant connectors to see if Vcc can be raised.

I will also change GPS_GNSS_Mode to 3, see if it works, as my outdated NEO 6M GPS does not support GLONASS. In fact,

my 2 other NEO 6M GPS do not get 3D fix recently. They were working very well 6-9 months ago.

Thank you.


Hi Shawn,

For your info, I managed to change to loiter mode when airborne, just by changing the GPS_GNSS_MODE to 3 without

changing any other parameter, using flight battery at storage level. I suspect there is some fundamental change in

the signal from GPS satellites recently. See attached log.

Anyway, the low Vcc is still an issue to deal with.



(Attachment 2020-12-20 13-39-39 Binary log.bin is missing)

The attachment was too big to upload in my last email. Here is the link to it :–

no access to the log file

Hi All,
My hex Tarot 680Pro with flight Controller Pixhawk 2.4.7 having Copter 4.0.7 gives same error “mode change failed loiter required position” that too before takeoff, as per my observation GPS is not getting signal,but I am not sure it issue with GPS module or Pixhawk or i miss any setting, because I live in village with full GPS signal for mobile.
Earlier i was using below site to analyze log
Unfortunately its not available now, sharing my log file, please find below link.

Set FENCE_ENABLE,1 and wait for the green LED indicating a good 3D fix, then Loiter mode will be possible.
Set GPS_GNSS_MODE,65 to limit the number of constellations, low-end GPS units cant handle more than 2 and update rate slows significantly.

1 Like

Thanks for quick reply , I was just searching for error in document and found AFS_WP_GPS_LOSS, but that parameter looks retired in latest 4.0.7, i was just planning to enable GPS failsafe to alt hold mode.
Also Shawn, i did not get why it crashed and landed?

It’s a bit confusing around that whole “touched the ground, tried to rise, then move and crash” stage.
The quad is in Land mode for that, and you are over-riding with RC input, so behaviour might not be as expected.
Always just switch to AltHold or Stabilise if strange things are happening.

I think general tuning plays a role. Pitch tuning seems very good, but roll needs some work.
ATC_ANG_RLL_P,3.033925 is very low. Try increasing this to 6 (and more in small steps). If you see oscillations then back it off a little. You should be able to get it up as high as the Pitch value of 9.35.
ATC_ACCEL_R_MAX is quite different to it’s Pitch mate too.

Did you start with the Initial Parameters spreadsheet or MissionPlanner Alt A plugin?
Set this before the next flight too:
Just do some AltHold hovering and maybe some gentle movements, then land - let’s see that log.

After tuning is fixed, you might want to check and assess your Land params, something like this for a start
then set the speed values based on stability
-> LAND_SPEED_HIGH = maximum descent rate with a slight amount of instability
-> LAND_SPEED = descent rate with total stability, but NOT so slow that landing is not detected
You test the descent rates in Stabilise mode, find the fastest safe descent rate (that you like the look of), then check in the log for what it actually was and use that to set LAND_SPEED_HIGH

1 Like

Tons of thanks Shawn @xfacta, Generally i do auto-tuning, I just installed new firmware 4.0.7 and I am trying to auto tune, but as loiter is not working I could not switch to auto-tune, after auto-tune, we have to land and disarm to save auto tuning values, and its difficult to land in alt-hold mode, I always prefer to have loiter for landing.

@xfacta any way to set GPS fail-safe to switch flight mode to altitude hold, again its risky when on mission, its hard to control when it not visible.

May be setting GPS fail safe to Smart RTL can help, again how it will find home location as GPS already failed.

RTL or SmartRTL, in fact any of the GPS-assisted modes, wont work if you lose GPS signal (or comms)
Probably get a more up-to-date GPS unit if you are having trouble.

1 Like

Best to have it set to LAND, decreasing speed and you should be flying out of danger so fail safe LAND is what i would advise for GPS fail safe.

Its based of the FS_EKF_ACTION param. I have it set to 1

Thanks , I am not sure whether its GPS module problem or its Pixhawk, once I identify it, i shall replace it.

After auto tune autoanalysis of syslog result is
No of lines 501088
Duration 0:12:14
Vehicletype ArduCopter
Firmware Version V4.0.7
Firmware Hash 0bb18a15
Hardware Type
Free Mem 0
Skipped Lines 0
Test: Autotune = GOOD - [+] Autotune 8284-488069

Test: Brownout = GOOD -
Test: Compass = GOOD - mag_field interference within limits (23.53%)

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = FAIL - ERR found: CRASH
Test: GPS = GOOD -
Test: IMU Mismatch = GOOD - (Mismatch: 0.47, WARN: 0.75, FAIL: 1.50)
Test: Motor Balance = GOOD - Motor channel averages = [1574, 1562, 1577, 1556, 1595, 1537]
Average motor output = 1566
Difference between min and max motor averages = 58
Test: NaNs = FAIL - Found NaN in CTUN.DSAlt

Test: OpticalFlow = FAIL - FAIL: no optical flow data

Test: Parameters = FAIL - ‘MAG_ENABLE’ not found
Test: PM = GOOD -
Test: Pitch/Roll = GOOD -
Test: Thrust = GOOD -
Test: VCC = UNKNOWN - No CURR log data

Auto Analysis is out of data and mostly useless.

From your previous log you have an intermittent GPS failure. GPA Delta should be ~200ms and Status should be 3 or 4. Bad module or wiring.

And those PID’s values look bad.


Auto Tune did not do well for this craft as configured.

Sharing latest log after auto tune

That’s the Auto Tune log. Fly it around with some aggressive pitch and roll and see how it does. At least the P/R PID’s are more inline now. Why didn;t you configure the Dynamic Notch Filter before running Auto Tune? Also, you have MOT_SPIN_ARM higher than MOT_SPIN_MIN.

1 Like

Thanks, all corrected now, will fly it and update.

Please open a new topic. None of this has anything to do with “loiter requires position”

1 Like

Ok, deleted post from here and created under Pixhawk autotune crash.