Facing problems with DISARMING ON LANDING

I am using Pixhawk 2.1 with Firmware version 3.6.9, I went out to test my tethered hexacopter yesterday, I calibrated each and everything. I have tested my other hexa frames but this time I faced a couple of very strange behaviour that has never happened to me ever before.
I faced the following problem:

  1. I made a two-point auto mission first one was take off and another one was to hold the position. Both waypoints had the same altitude. I switched the copter on AUTO mode then suddenly after attaining the provided altitude the ‘‘IMU did the YAW RE-Alignment’’ in the air and did the yaw of about 60 degrees which has never happened in the air.
    Can anyone explain why did this happen?

2)The other issue I faced was during the landing, I tried to land the copter in two ways one was through RTL and another was in loiter mode.
In RTL the copter came down with high speed and landed. After landing, the motors did not slow down at all instead it was trying to attain more speed, I tried to disarm motors using RC, it did not disarm it and ultimately flipped.
Pixhawk should have detected the crash and stopped the motors but motors did not stop at all I had to disconnect the power source to stop the motors from running.

The same thing happened when I tried to land using LOITER mode but this time the crash was detected and motors were stopped.

My entire concern is why did copter did the yaw movement in the air and most important part is why it did not disarm the motors after landing.

You need to post a log in order for people to be able to assist

trying to upload the .bin file but it is not uploading. please try this link.